Algoritimo

Disponível somente no TrabalhosFeitos
  • Páginas : 5 (1085 palavras )
  • Download(s) : 0
  • Publicado : 20 de maio de 2012
Ler documento completo
Amostra do texto
EXERCICIOS LISTA 6

5. Faça o algoritmo que calcule e apresente quanto deve ser pago por um produto considerando a leitura do preço de etiqueta (PE) e o código da condição de pagamento (CP). Apresente também a mensagem conforme a condição de pagamento. Utilize para os cálculos a tabela de condições de pagamento a seguir:
Código da condição de pagamento Condição de pagamento
1 À vista emdinheiro ou cheque, com 10% de desconto!
2 À vista com cartão de crédito, com 5% de desconto!
3 Em 2 vezes, preço normal de etiqueta sem juros!
4 Em 3 vezes, preço de etiqueta com acréscimo de 10%!
ATENÇÃO! O enunciado não solicita a exibição do valor de descontos e nem o valor de parcelas!

Programa 5
VAR
real PE,VALOR
inteiro CP
INICIO
escreva (“Entre com opreço que esta na etiqueta:”)
leia(PE)
escreva (“Entre com o código da condição de pagamento de 1 a 4:”)
leia(CP)
se (CP=1) então
VALOR<-CP-CP*0.10
escreva (“Valor do produto à vista com desconto de 10%, pagamento em dinheiro ou cheque”,VALOR)
senão
se (CP=2) então
VALOR<-CP-CP*0.05
escreva (“Valor do produto à vista com desconto de 5%, pagamento comcartão de credito”,VALOR)
senão
se (CP=3) então
VALOR<-CP
escreva (“Valor do produto sem desconto, pagamento em 2 vezes”,VALOR)
senão
se (CP=4) então
VALOR<-CP+CP*0.10
escreva (“Valor do produto com acréscimo de 10%, pagamento em 3 vezes”,VALOR)
fimse
fimse
fimse
fimse
fim

A

“Entre com o código da condição de pagamento de 1 a 4:”
CP
“Entre com o preçoque esta na etiqueta:”)
PE
real PE,VALOR
inteiro CP

INÍCIO

CP=1

F V


VALOR<-CP-CP*0.10

“Valor do produto à vista com desconto de 5%, pagamento com cartão de crédito”,VALOR
A

CP=2

F V
CP=3


“Valor do produto à vista com desconto de 10%, pagamento em dinheiro oucheque”,VALOR


VALOR<-CP-CP*0.05

F V


CP=4

VALOR<-CP
F V

“Valor do produto sem desconto, pagamento em 2 vezes”,VALOR

VALOR<-CP+CP*0.10

“Valor do produto com acréscimo de 10%, pagamento em 3 vezes”,VALOR

FIM

“Entrecom o valor do numero A:”
“Entre com o valor do numero B:”
B
real A,B,RESULTADO

INÍCIO
A
6. Faça o algoritmo que leia dois números (A e B). Caso A seja igual a B, apresentar a soma dos
dois. Caso um seja maior que o outro, apresentar a diferença entre os dois números (sempre
lembrando que a diferença entre dois números é SEMPRE positiva).

Programa 6
VAR
real A,B,RESULTADO
INICIOescreva (“Entre com o valor do numero A:”)
leia(A)
escreva (“Entre com o valor do numero B:”)
leia(B)
se (A=B) então
RESULTADO<-A+B
escreva (“A soma de A e B é (são):”,RESULTADO)
senão
se (A>B ) então
RESULTADO<-A-B
escreva (“A diferença do resultado é:”,RESULTADO)
senão
se (B>A ) entãoRESULTADO<-B-A
escreva (“A diferença do resultado é:”,RESULTADO)
fimse
fimse
fimse
A=B

fim
F V

RESULTADO<-A+B
A>B

F V

B<A

RESULTADO<-
A-B

“A soma de A e B é (são):”,RESULTADO
F V


RESULTADO<-
B-A

“A Diferença do resultado é:”,RESULTADO

“A Diferença do resultadoé:”,RESULTADO

FIM

7. Faça o algoritmo que leia o ano de nascimento de uma pessoa (AN) e calcule a sua idade. O
algoritmo também deve verificar e exibir se essa pessoa já tem idade para votar (16 anos ou
mais), se já pode conseguir a sua carteira de habilitação (18 anos ou mais) ou se não pode
nenhuma das duas coisas. Exibir a idade da pessoa.
A

Programa 7
VAR
Inteiro AN,AA,IDADE
AN...
tracking img