Trabalho atps algoritmos e programação

Páginas: 2 (328 palavras) Publicado: 7 de abril de 2012
Etapa 1

Passo 1

Algoritmo Narrativo:

Entre com o Valor do Dólar: x
Entre com a Quantia em Real: x
Efetue o Calculo
Quantia em Dólar = Quantia em Real / Valor do Dólar.
Exibir o ResultadoA Quantia em Real transformado em Dólares é: x

Pseudo Código:

Algoritmo “Conversor I”
// Função; Conversor de Moedas
// Autores: Grupo ATPS
// Data: 10/04/2012
Var
Dólar, Reais, Qtdolar:Real
Inicio
Limpatela
Escreva (“Entre com o Valor do Dólar:”)
Leia (Dólar)
Escreva (“Entre com a Quantia em Reais:”)
Leia (Reais)
Qtdolar: = Reais / Dólar
Escreva (“A quantia em ReaisTransformada para Dólares é”, Qtdolar)
Fimalgoritmo

Fluxograma:

Apresentação do resultado
Efetuando o Calculo
Fim do Algoritmo
Entrada de Dados
Entrada de Dados
Inicio do Algoritmo

Passo 2Pseudocódigo:

Algoritmo “Conversor II”
// Função: Conversor de Moedas
// Autores: Grupo ATPS
// Data: 10/04/2012
Var
DolarAM, DolarCN, Euro, Reais, QtdolarAM, QtdolarCN, Qteuro : Real
InicioLimpatela
Escreva (“Entre com o Valor do Dólar Americano:”)
Leia (DolarAM)
Escreva (“Entre com o Valor do Dólar Canadense:”)
Leia (DolarCN)
Escreva (“Entre com o Valor do Euro:”)
Leia (Euro)Escreva (“Entre com a Quantia em Reais:”)
Leia (Reais)
QtdolarAM: = Reais / DolarAM
QtdolarCN: = Reais / DolarCN
Qteuro: = Reais / Euro
Escreva (“A quantia em Reais Transformada para DólaresAmericanos é:” (QtdolarAM)
Escreva (“A quantia em Reais Transformada para Dólares Canadense é:” (QtdolarCN)
Escreva (“A quantia em Reais Transformada para Euros é:” (Qteuro)
Fimalgoritmo

Fluxograma:Apresentação do resultado
Fim do Algoritmo
Inicio do Algoritmo
Efetuando o Calculo
Entrada de Dados
Entrada de Dados
Inicio
Entre com valor do Dólar Americano US$.

Entre com o Valor doDólar Canadense CDN$.

Entre com o valor do Euro:
Entre com a Quantia em Reais.
QT. Dólar US$ = QT. Em Reais / Valor Dólar US$

QT. Dólar CDN$ = QT. Em Reais / Valor Dólar CDN$

QT. Euro = QT....
Ler documento completo

Por favor, assinar para o acesso.

Estes textos também podem ser interessantes

  • ATPS Algoritmos e Programação
  • Algoritmo programação atps
  • Atps algoritmo e programacao
  • atps algoritmo e programação
  • ATPS Algoritmo e Programação
  • Atps de algorítmo e programação
  • ATPS Algoritmo e Programação
  • ATPS Algoritmo e programação

Seja um membro do Trabalhos Feitos

CADASTRE-SE AGORA!