Pseudo Código para o calculo de Determinantes

Páginas: 2 (342 palavras) Publicado: 16 de novembro de 2014
Programa Determinante Matriz Quadrada Ordem “n”

Programa DeterminanteMatrizN;
Inicio;
{ Definição de Variáveis e Tipos Globais }
Tipo
Mat = Matriz[1..n,1..n] de Inteiros;
Mat:
M;
Inteiro:Det, n, x, y;
{ Modulo para Calculo de Determinante de Matriz Quadrada de ordem N}
Modulo Determinante(Inteiro: Det, n; Matriz[1..n,1..n] de Inteiros: M; Inteiro: L, C;);
Inicio;
{ Definição deVariáveis Locais }
Tipo
Mat = Matriz[1..n-1,1..n-1] de inteiros;
Tipo
Vet = vetor[1..n] de inteiros;
Vet:
D1, D2;
Mat:
MA;
Inteiro:
X1, X2, Y1, Y2, Det2, Cof;
Inteiro:
Det1, Det2, x, y, z,w, n;
Escolha
Caso n = 1:
{ Determinante Matriz ordem 1}
Det ← M[1,1];
Caso n>1 e n n ) então
{ Se coluna > n }
z ← z – n;
{ pega a partir da col 1 }
FimSe;
D1[x+1] ← D1[x+1] * M[y,z];
{Diagonal Principal }
w ← n – z + 1;
D2[x+1] ← D2[x+1] * M[y,w];
{ Diagonal Secundária }
FimPara;
Det1 ← Det1 + D1[x+1];
{ Diagonal Principal }
Det2 ← Det2 + D2[x+1];
{ Diagonal Secundária }FimPara;
Det ← Det1 – Det2;

Caso Contrário:
{ Determinante Matriz ordem > 3}
Se L > 0 então
{ Reduz a matriz ... }
X2 ← 0;
Para X1 = 1 até n
X2 ← X2 + 1;
Se X1 L então
{ ... tirando a linhaL ... }
Y2 ← 0;
Para Y1 = 1 até n
Y2 ← Y2 + 1;
Se Y2 C então
{ ... e a coluna C ... }
MA[X2, Y2] ← M[X1,Y1];
FimSe;
FimPara;
FimSe;
FimPara;
d ← n – 1;
{ ... e diminui a ordem da matriz.}
Senão
{ para a primeira vez }
MA ← M;
d ← n;
FimSe;
Det ← 0;
{ Calcula Determinante por Laplace }
Para X2= 1 até d
Determinante(Det2, d, MA, 1, X2);
{ Det. da matriz reduzida}
Cof ←POT(-1,1+X2) * Det2;
{ Calculo do Cofator }
Det ← Det + M[1,X2] * Cof;
{ Teorema de Laplace }
FimPara;
FimEscolha;
Fim;
{ Programa Principal, Carrega a Matriz e Calcula o Determinante }
{ Dimensãoda matriz }
Leia(n);
{ Carrega a matriz }
Para x = 1 até n
Para y = 1 até n
Leia(M[x,y]);
FimPara;
FimPara;
{ Calcula Determinante }
Determinante(Det, n, M, 0, 0);
Escreve(‘O Determinante...
Ler documento completo

Por favor, assinar para o acesso.

Estes textos também podem ser interessantes

  • pseudo código
  • Calculo determinantes
  • Calculo determinante
  • Calculo de determinantes
  • Relação ente pseudo código e c
  • Calculo numérico
  • Comparação entre algoritmos para cálculo de determinante
  • Calculo de determinantes(algebra linear)

Seja um membro do Trabalhos Feitos

CADASTRE-SE AGORA!