Pré Calculo

Páginas: 5 (1198 palavras) Publicado: 12 de novembro de 2014






UNIVERSIDADE NORTE DO PARANÁ
ENGENHARIA CIVIL - NOTURNO – DEPENDÊNCIA

EVERTON DIEGO GARBOSSI DE OLIVEIRA










ALGORITIMO E PROGRAMAÇÃO
Lista de Exercício 01


















Londrina
2014

1) Lógica de Programação é a técnica de desenvolver algoritmos (sequências lógicas) para atingir determinados objetivos dentro de certas regras baseadasna Lógica matemática e em outras teorias básicas da Ciência da Computação e que depois são adaptados para a Linguagem de Programação utilizada pelo programador para construir seu software.

2) Fazer um sanduíche:
*Pegar o pão
*Cortar o pão ao meio
*Pegar a maionese
*Passar a maionese no pão
*Pegar e cortar alface e tomate
*Pegar o hamburguer
*Fritar o hambúrguer
*Colocar o hamburguer nopão

Ir para a escola
*Acordar cedo
*Ir ao banheiro
*Abrir o armário para escolher a roupa
*Se o tempo estiver quente pegar uma camiseta e uma calça jeans; caso contrário, pegar um agasalho e uma calça jeans.
*Vestir a roupa escolhida
*Tomar café
*Pegar uma condução
*Descer próximo a escola

Trocar uma lâmpada
*Pegar uma lâmpada nova
*Pegar uma escada
*Posicionar a escada embaixoda lâmpada queimada
*Subir a escada com a lâmpada nova na mão
*Retirar a lâmpada queimada
*Colocar a lâmpada nova
*Descer da escada
*Testar o interruptor
*Guardar a escada
*Jogar a lâmpada velha no lixo

3) Os mais utilizados são: Diagrama de Blocos - Fluxograma de Processo Simples - Fluxograma Funcional - Fluxograma Físico ou Geográfico - Fluxograma ANSI

04 a)







04 b)04 c)





04 d)









05 a) 10 - 05 b) 12 - 05 c) 4, 4, 7,75

06)
( V ) A ( V ) n1
( I ) 1º Num ( I ) base nova
( I ) 1n ( I ) leia
( V ) casa ( V ) casa_velha
( I ) Nº1 ( I ) inteiro
( I ) 1% ( I ) algoritmo

07 )











algoritmo/*programa*/
declare n1, n2, n3, p1, p2, p3 resultado NUMERICO
escreva(“Digite n1, n2, n3”)
leia n1, n2, n3
escreva (“Digite p1, p2, p3”)
resultado ((n1*p1)+(n2*p2)+(n3*p3))/(p1+p2+p3)
escreva (“A média ponderada é:”, resultado)
fim_algoritmo




08 )




algoritmo/*programa*/
declare salario, percentual_de_aumento, novo_salario NUMERICO
escreva (“Digite o salário”)
leia salario
escreva (“percentual de aumento”)
novo_salario((salário*perdentual_de_aumento)/100)+salario
escreva (“Novo salário é:”, novo_salario)
fim_algoritmo


09 )




algoritmo/*programa*/
declare a, b, substituir NUMERICO
escreva (“Digite A=28”)
leia 28
escreva (“B=16”)
leia 16
a ( b )
b ( a )
escreva (“Variável A:”, a)
escreva (“Variável B:”, b)
fim_algoritmo

10 )






algoritmo/*programa*/
declarehora1, minuto1, hora2, minuto2 : inteiro
escreva ("Digite a Hora de entrada") 
leia (hora1) 
se (hora1 >= 24) entao 
escreva ("Hora invalida!") 
fimse
ate (hora1 < 24)repita 
escreva ("Digite a minuto de entrada") 
leia (minuto1) 
se (minuto1 >= 60) entao 
escreva ("Minuto invalido!") 
fimse
ate (minuto1 < 60)
escreva ("Digite a Hora de Saída") 
leia (hora2) 
se (hora2 >= 24)entao 
escreva ("Hora invalida!") 
fimse
ate (hora2 < 24) 
escreva ("Digite a minuto de Saída") 
leia (minuto2) 
se (minuto2 >= 60) entao 
escreva ("Minuto invalido!") 
fimse
ate (minuto2 < 60)
escreval ("Horário Total:" , hora1-hora2 ,":", minuto1-minuto2)
fim_algoritmo

12 )









algoritmo/*programa*/
declare nome_aluno, bim1, bim2, bim3, bim4 resultado NUMERICO
escreva(“Digite nome do aluno”)
leia nome_aluno
escreva (“Digite as notas dos 4 bimestres”)
leia bim1, bim2, bim3, bim4
resultado (bim1+bim2+bim3+bim4)/4
escreva (“A média aritimética é:”, resultado)
fim_algoritmo

13 )

algoritmo/*programa*/
declare fahrenheit, celsius NUMERICO
escreva (“Digite a temperatura em fahrenheit”)
leia fehrenheit
celsius fehrenheit...
Ler documento completo

Por favor, assinar para o acesso.

Estes textos também podem ser interessantes

  • pre calculo
  • Pré-calculo
  • pré-calculo
  • pré calculo
  • Pré-Cálculo
  • Pre-Calculo
  • pré calculo
  • Pre calculo

Seja um membro do Trabalhos Feitos

CADASTRE-SE AGORA!