Logica de Programa o ap 5

Páginas: 5 (1172 palavras) Publicado: 27 de julho de 2015
13/07/2015

AVA UNIVIRTUS

APOL 5
RAMON BETERLI DA SILVA - RU: 1118322 Nota: 80

PROTOCOLO: 20150630111832231AB40

Disciplina(s):
Lógica de Programação e Algoritmos
Data de início:

01/07/2015 19:58

Prazo máximo entrega:

-

Data de entrega:

01/07/2015 21:03

Questão 1/10
Considerando o bloco de código de um algoritmo mostrado abaixo qual seria a alternativa adequada para substituí-lo?preco[1]<-150.00
preco [2]<-250.00
preco[3]<-10.00
preco [4]<-40.00
preco[5]<-120.00
preco [6]<-500.00
preco[7]<-12.00
preco [8]<-13.00

A

 n<-8
 para i de 1 ate n faca
    leia(preco(i))   
 fimpara

B

 n<-8
 para i de 1 ate n faca
    leia(preco[i])   
 fimpara



Você acertou!
Assunto das aulas 7, 8, 9 e 10

C

para i de 1 ate n faca
    leia(preco(k))   
fimparahttp://univirtus­277877701.sa­east­1.elb.amazonaws.com/ava/web/#/ava/AvaliacaoUsuarioHistorico/26477/novo/1

1/10

13/07/2015

D

AVA UNIVIRTUS

para i de 1 ate n faca
    leia(preco)   
fimpara

Questão 2/10
Avalie o bloco de código de um algoritmo mostrado abaixo, e selecione a alternativa adequada para substituí-lo.
preco[1,1]<-1
preco [1,2]<-2
preco[1,3]<-3
preco [1,4]<-4
preco[2,1]<-23.00
preco [2,2]<-500.00preco[2,3]<-12.00
preco [2,4]<-13.00

A

para i de 1 ate 2 faca
     para j de 1 ate 4 faca
         leia(preco[i,j])
     fimpara
fimpara



Você acertou!
Conteúdo abordado nas aulas 7, 8, 9 e 10

B

para i de 1 ate 2 faca
     para j de 1 ate 4 faca
         leia(preco(i,j))
     fimpara
fimpara

C

para i de 1 ate 2 faca
     para j de 1 ate 4 faca
         leia(preco[j,i])
     fimpara
fimpara

Dhttp://univirtus­277877701.sa­east­1.elb.amazonaws.com/ava/web/#/ava/AvaliacaoUsuarioHistorico/26477/novo/1

2/10

13/07/2015

AVA UNIVIRTUS

para i de 1 ate 2 faca
     para j de 1 ate 4 faca
         leia(preco[i])
     fimpara
fimpara

Questão 3/10
O que a função definida no algoritmo abaixo faz?
 
algoritmo "Função"
// Seção de Declarações
var
 
n1,n2,resultado1:real
 
funcaofsx(v1,v2:real):real
var
  total:real
inicio
  total<-v1+(v2*v2)
  retorne total
fimfuncao
 
inicio
// Seção de Comandos
 
escreva("Digite um valor:")
leia(n1)
escreva("Digite o segundo valor:")
leia(n2)
 
resultado1<-fsx(n1,n2)
 
escreval("O valor da operação de ",n1," com ",n2," =",resultado1)
 
fimalgoritmo
A

A soma dos quadrados dos valores.http://univirtus­277877701.sa­east­1.elb.amazonaws.com/ava/web/#/ava/AvaliacaoUsuarioHistorico/26477/novo/1

3/10

13/07/2015

B

AVA UNIVIRTUS

A soma do primeiro valor com o quadrado do segundo valor.



Você acertou!
Conteúdo abordado nas aulas 7, 8, 9 e 10.

C

A soma do quadrado do primeiro valor pelo segundo valor.

D

O quadrado das somas dos valores.

Questão 4/10
Para que o programa abaixo faça a divisão de dois valores, sendo o primeiro pelo segundo,quais seriam as linhas de código mais
adequadas a substituirem as linhas pontilhadas?
algoritmo "Função"
// Seção de Declarações
var
 
n1,n2,x:real
 
funcao fsx(v1,v2:real):real
var
total:real
............................................
............................................
............................................
 
fimfuncao
 
 
inicio
// Seção de Comandos
 
escreva("Digite umvalor:")
leia(n1)
escreva("Digite o segundo valor:")
leia(n2)
 
x<-fsx(n1,n2)
 

http://univirtus­277877701.sa­east­1.elb.amazonaws.com/ava/web/#/ava/AvaliacaoUsuarioHistorico/26477/novo/1

4/10

13/07/2015

AVA UNIVIRTUS

escreval("O valor da operação de ",n1," com ",n2," =",x)
 
 fimalgoritmo

A

inicio
total<-v1/v2
retorne total



Você acertou!
Conteúdo abordado nas aulas 7, 8, 9 e 10.

Binicio
total<-v1/2
retorne resultado

C

inicio
 total<-v2/v1
 retorne total

D

inicio
total<-v2/2
retorne resultado

Questão 5/10
Para que o programa abaixo faça a média ponderada, quais seriam as linhas de código mais adequadas para substituírem a parte
pontilhada?
 
algoritmo "Função"
// Seção de Declarações
var
 
n1,n2,n3,n4,x:real
 
funcao fsx(v1,v2,v3,v4:real):real
var
total:real...
Ler documento completo

Por favor, assinar para o acesso.

Estes textos também podem ser interessantes

  • Logica De Programa O
  • Logica- 5
  • APS 5 SEM
  • aps 5
  • APS 5 SEM
  • Logica De Programa O Prof
  • logica de programa ao resolvido
  • questoes de logica da programa o

Seja um membro do Trabalhos Feitos

CADASTRE-SE AGORA!