Lógica de programação (uninove)

Páginas: 2 (354 palavras) Publicado: 21 de maio de 2012
1. Elabore um algoritmo que efetue a leitura de um valor numérico inteiro positivo ou negativo representado pela variável N e apresente o valor lido como positivo. Sugestão: Se o número lido fornegativo multiplique-o por -1.

Pseudocódigo

Programa número_positivo
var
N: inteiro
Inicio
escreva “Digite um Número”
leia N
se(N>0)então
escreva N
senãose(N0){
printf("%i\n",N);
}
else{
if(N6)então
escreva "Aprovado"
escreva "Media Final:",M1
senãoescreva "Digite a nota do Exame"
leia NE
M2←(M1+NE)/2
se(M2>5)então
escreva “Aprovado em Exame”
escreva “Média Final:”, M2senão
escreva "Reprovado”
escreva “Média Final:”, M2
fim_se
fim_se
fim


Código em C++

#include
#include
floatN1,N2,N3,N4,M1,M2,NE;
main()
{
printf("Digite as quatro notas do Aluno\n");
scanf("%f%f%f%f",&N1,&N2,&N3,&N4);
M1=(N1+N2+N3+N4)/4;
if(M1>6){printf("Aprovado\n");
printf("Media Final:%f\n",M1);
}
else{
printf("Digite a nota do Exame\n");
scanf("%f",&NE);
M2=(M1+NE)/2;if(M2>5)
printf("Aprovado em Exame\nMedia Final:%f\n",M2);
else
printf("Reprovado\nMedia Final:%f\n",M2);
}system("pause");
}








Fluxograma



[pic]










3) Construa um algoritmo que calcule as raízes de uma equação de 2º grau, A.x 2+B.x+C=0 . O programa deve ler as variáveis A, B e C ecalcular o valor de DELTA=B2−4.A.C . Se DELTA 0 o programa deve calcular e exibir as duas raízes X1←(-B+Delta↑(1/2))/(2*A) e X2←(-B-Delta↑(1/2))/(2*A). No caso de DELTA=0 o programa deve exibir...
Ler documento completo

Por favor, assinar para o acesso.

Estes textos também podem ser interessantes

  • Lógica de Programação
  • Logica de programação
  • Logica de programação
  • Lógica programação
  • logica de Programação
  • Logica de programação
  • Logica de Programação
  • Logica de programação

Seja um membro do Trabalhos Feitos

CADASTRE-SE AGORA!