Exercicios classificação e pesquisa

Páginas: 2 (324 palavras) Publicado: 1 de outubro de 2012
Classificação e Pesquisa Resolução Exercícios da Aula 01

Antonio Felicio Netto antonio.felicio@aedu.com 4º Semestre Ciência da Computação

Exercícios :
1. Escreva o algoritmo que realize ocadastro de 10 números inteiros em um vetor. 2. Escreva o algoritmo que realize o cadastro de 10 números inteiros distintos em um vetor.

3. Dado um vetor de nome “vet” que possua 50 posições,realize a verificação a quantidade de incidência de cada número e faça a sua impressão ao usuário.

Resolução do Exercício 1
1. Escreva o algoritmo que realize o cadastro de 10 números inteirosem um vetor. Algoritmo Vetor Variáveis Vetor [10] : int I:int Inicio Para i = 0, i< 10, incremento 1 Leia (vetor[i]) Fimpara Fim

Resolução do Exercício 2
2. Escreva o algoritmo que realize ocadastro de 10 números inteiros distintos em um vetor. Algoritmo VetorDistinto Variáveis Vetor [10] : int i, j:int Inicio i =0 enquanto (i < 10) faça escreva (‘Digite um valor para posição ‘+ i) leia(Vetor[i]) se (existe (i) == falso) então i = i+1 fimse fimenquanto Fim Função existe (posição:int): booleano Para j=0, j< posição, incremento 1 Se (vetor[j] = vetor[posição]) então Retorna(verdadeiro) Fimpara Retorna (falso) fimfunção

Resolução do Exercício 3
3. Dado um vetor de nome “vet” que possua 50 posições, realize a verificação a quantidade de incidência de cada número e façaa sua impressão ao usuário. Algoritmo VerificaQuantidade Variáveis Vet [50], Contador[50,2] : int i, j:int Inicio carregaVetor (Vet[ ]) // função não // tratada Para i=0, i< 49, incremento 1avaliaIncidencia (Vet[i]) Fimpara i=0 enquanto (Contator[i,0] nulo) faça escreva (‘O valor ‘+ Contator[i,0]+ ‘ teve ‘+ Contator[i,1]+ ‘ incidencias’) i = i+ 1 fimenquanto Fim Função avaliaIncidencia(valor:int): nulo j=0 enquanto (Contator[j,0] nulo) se (Contator[j,0]) = valor) entao pare fimse j = j+1 fimenquanto Contator[j,0 ] = valor Contator[j,1 ] = Contator[j,1 ] +1 Retorna () fimfunção...
Ler documento completo

Por favor, assinar para o acesso.

Estes textos também podem ser interessantes

  • Classificação de pesquisa
  • classificação e pesquisa
  • CLASSIFICAÇÃO E PESQUISA
  • Classificação e pesquisa
  • Classificação pesquisa
  • Classificação e Pesquisa
  • Classificação das pesquisas
  • Classificação das pesquisas

Seja um membro do Trabalhos Feitos

CADASTRE-SE AGORA!