exercícios resolidos

Páginas: 2 (281 palavras) Publicado: 9 de abril de 2014
Assunto: Estrutura Condicional e de Repetição

Estrutura Condicional
1) Defina e dê um exemplo de cada uma das seguintes estruturas de Seleção
a) Simples: Quando existe apenas 1comando a ser executado,

início
// declaração de variáveis
real: N1, N2, N3, N4, // notas bimestrais
MA; // média anual
// entrada de dados
leia (N1, N2, N3, N4);
// processamento
MA ←(N1 + N2 + N3 + N4) / 4;
// saída de dados
escreva (MA);
se (MA >= 7) então
escreva (“Aluno Aprovado !”); // 1 instrução: bloco é desnecessário
fimse;
fim
b) Composta: Quando acondição for verdadeira o “bloco verdade” é executado
• Quando a condição for falsa o “bloco falsidade” é executado

início
// declaração de variáveis
real: N1, N2, N3, N4, // notasbimestrais
MA; // média anual
leia (N1, N2, N3, N4);
MA ← (N1 + N2 + N3 + N4) / 4;
escreva (MA);
se (MA >= 7) então
início
escreva (“Aluno Aprovado !”);
escreva (“Parabéns !”);
fim;senão
início
escreva (“Aluno Reprovado !”);
escreva (“Estude mais !”);
fim;
fimse;
fim.

c) Encadeada Ocorre quando uma seleção tem como ação uma outra seleção

início
inteiro: A,B, C; // tamanho dos lados
leia (A, B, C);
se (A= 25) e (imc < 30)
Escreva: (“acima do peso”);
senao (imc >= 30)
Escreva: (“odeso”);Fimse.
Pause.
Fim

5) A empresa XYZ decidiu conceder um aumento de salários a seus funcionários de acordo com a tabela abaixo:
SALÁRIO ATUAL ÍNDICE DE AUMENTO
0 – 400 15%
401 – 70012%
701 – 1000 10%
1001 – 1800 7%
1801 – 2500 4%
ACIMA DE 2500 SEM AUMENTO
Escrever um algoritmo que leia, para cada funcionário, o seu nome e o seu salário atual. Após receber estesdados, o algoritmo calcula o novo salário e escreve na tela as seguintes informações:


var
salario, aumento, novo_sal: real
inicio
leia (salario)
se (salario
Ler documento completo

Por favor, assinar para o acesso.

Estes textos também podem ser interessantes

  • Exercícios
  • Exercicios
  • Exercicios
  • exercícios
  • Exercícios
  • Exercicios
  • Exercícios
  • exercicios

Seja um membro do Trabalhos Feitos

CADASTRE-SE AGORA!