conversor de real para dolar

Páginas: 2 (253 palavras) Publicado: 17 de setembro de 2014
ETAPA 1
PASSO 1

Algoritmo em Descrição Narrativa

Algoritmo
Informe um Valor;
Leia um Valor para dólar;
Efetua conversão de dólar para reais, multiplicando valor dedólar pela cotação dodólar;
Informa o Valor da Variável total.

Algoritmo descrição pseudocódigo
Algoritmo
Real real1, dolar;
Escreva “informe um valor”;
Leia dólar;real1 = dolar/0.619;
Escreva “O Valor em Reaise”;
Escreva total;
Fim Algoritmo

Algoritmo em Fluxograma
Inicio
Inicio

real1 = dolar/0.619
real1 = dolar/0.619

TotalTotal

Fim
FimPASSO 2

Algoritmo em Pseudocódigo
Algoritmo
real dolar, euro, dolarc, reald, realeur, realdc ;
Escreva" Insira o valor em Dolar a ser convertido:";
Leia“dolar”;
Escreva "Insira ovalor em Euro a ser convertido:";
Leia “euro”;
Escreva "Insira o valor em Dolar canadense a ser convertido:";
Leia “dolarc”;
reald = dolar/0.619;Escreva "O valor de Dolarpara reais e ", reald);
realeur = euro/0.608;
Escreva "O valor de Euro para reais e ", realeur);
realdc = dolardc/0.437;
Escreva "O valor de Dolarcanadense para reais e ",realdc);
FimAlgorimo

Algoritmo em Fluxograma

Ler Dolar
Ler Dolar
Inicio
Inicio

dolar/0.619

dolar/0.619euro/0.608

euro/0.608dolarc/0.437

dolarc/0.437

REAL

REAL

Fim
Fim

PASSO 3

Pseudocódigo

Algoritmo
real dolar, dolarc, euro, reald, realdc, eurors ;
caractere escolha;Escreva”Informe qual a moeda para conversão”;
Escreva"1 – Dolar, 2 - Dolar Canadense, 3 - Euro ";
Leia”escolha”;
Se (escolha=1) então
Escreva ”informe o valor em dolar”;
Leia “dolar”;reald=dolar/0. 619;
Escreva ”O valor em reais e”, reald;
FimSe
Se (escolha=2) então
Escreva ”Informe o valor em Dolar Canadense”;
Leia”dolarc”;
realdc= dolarc/0. 437;
Ler documento completo

Por favor, assinar para o acesso.

Estes textos também podem ser interessantes

  • COMO TRANSFORMAR 500 DÓLARES EM UM FATURAMENTO DE 24 MILHÕES DE REAIS
  • Aula 4 Real E A Terceira Moeda Que Mais Perde Forca Ante O Dolar
  • Dolar
  • Dolar
  • Dolar
  • O dólar
  • Dolar
  • Dolar

Seja um membro do Trabalhos Feitos

CADASTRE-SE AGORA!