Calculo de média e fluxograma

Páginas: 2 (385 palavras) Publicado: 2 de outubro de 2012
Programa calcula_media;

var

nome_aluno,disciplina,permiti_exame : string[30];

vl_aprova,nota_1,nota_2,exame,media : real;

Inicio

media:=0;

Escreva(‘Programa para Calcular aMédia do Aluno’);

Escreva('Informe o Nome do Aluno:');

Leia (nome_aluno);

Escreva ('Informe a Disciplina:');

Leia (disciplina);

Escreva('Informe a Nota da Primeira Avaliação:');Leia (nota_1);

Escreva ('Informe a Nota da Segunda Avaliação:');

Leia (nota_2);

Escreva('informe o valor da Média para Aprovação:');

Leia(vl_aprova);

media= vl_aprova) entaoEscreva ('Aluno',nome_aluno,' Aprovado com média:',media)



senao

Escreva ('Aluno pode fazer Exame: SIM (S) ou NÃO (N):');

Leia (permiti_exame);



Se (permiti_exame='S') entaoinicio

Escreva ('Entre com a Nota da Prova de Exame:');

Leia (exame);

Escreva ('Informe o valor da Média para Aprovação:');

Leia (vl_aprova);

media= vl_aprova) entaoEscreva ('Aluno',nome_aluno,'Aprovado com Média :',media)

senao

Escreva('Aluno',nome_aluno,'Reprovado com Média :',media);

fimse

senao

Escreva('Aluno',nome_aluno,'Reprovado com Média :',media);

fimse

fim.

Testes realizados :
[pic]
Fig – Teste no sistema , com lançamento de notas que ficam acima ou igual a média informada.



[pic]
FIg. Teste comnotas lançadas com reprovação após Exame.


[pic]

Teste com notas Lançadas e Aluno sem direito a Exame

[pic]

Teste com lançamento de notas , e aprovação após Exame.

[pic]

[pic]Algoritmo para Cadastro de Aluno;

Programa Cadastro_aluno;

var

Nome_aluno,Ender_aluno,RG_aluno,CPF_aluno,Cidade_aluno,tel_aluno,Dtnasc_aluno, curso_aluno : string[45];novo_cadastro:string[1];



Inicio

Escreva (‘ Programa para Cadastro de NOVO ALUNO ‘ );

Escreva (‘Deseja fazer um novo cadastro (S) Sim ou (N) Não): ‘ );

Leia (novo_cadastro);...
Ler documento completo

Por favor, assinar para o acesso.

Estes textos também podem ser interessantes

  • Fluxograma de Média
  • Calculo de media temporal
  • Algoritmo calculo de média
  • Media de reprovação em calculo
  • Calculo de media em c
  • Cálculo da velocidade mediA
  • Calculo de erro de media
  • Calculo de média de notas (algoritmo em C)

Seja um membro do Trabalhos Feitos

CADASTRE-SE AGORA!