Algoritmos

Páginas: 6 (1433 palavras) Publicado: 11 de maio de 2014
Lista de Exercícios Algorítmos

01
Fazer Média de 02 idades
Algoritmo Media_02_idades
Declare
Real media id1,id2;
Iniciar
Escreva (“Digite a Idade 01”);
Leia(id1);
Escreva (“Digite a Idade 02”);
Leia(id2);
media = id1+ id2;
Escreva (“A média das idades é: ”,media);
Fim.
Fim Algoritmo


02
João quer comprar uma TV de R$ 1.000,00 reais e ele precisa dividir em 5parcelas. Crie um algoritmo para resolver o problema dele.
Algoritmo Tv
Declare
Real valor_parc, 5, 1000;
Iniciar
valor_parc = 1000/5;
Escreva (“O valor de cada parcela eh: ”, valor_parc);
Fim.
Fim Algoritmo

03
João quer comprar uma TV de R$ 1.000,00 reais e ele precisa dividir em parcelas. Crie um algoritmo que mostre a João quanto ficaria as parcelas independentes da quantidadede vezes que pretende dividir.
Algoritmo Tv_2
Declare
Real valor_parc, qtd_par, 1000;
Iniciar
Escreva (“Digite a quantidade de parcelas”);
Leia(qtd_par);
valor_parc = 1000/ qtd_par;
Escreva (“O valor de cada parcela eh:”, valor_parc);
Fim.
Fim Algoritmo

04
João quer comprar uma TV de X valor e ele precisa dividir em parcelas. Crie um algoritmo que mostre a João quantoficaria as parcelas independentes da quantidade de vezes que pretende dividir.
Algoritmo Tv_3
Declare
Real valor_parc, qtd_par, valor_tv;
Iniciar
Escreva (“Digite o valor da TV”);
Leia(valor_tv);
Escreva (“Digite a quantidade de parcelas”);
Leia(qtd_par);
valor_parc = valor_tv/ qtd_par;
Escreva (“O valor de cada parcela eh:: ”, valor_parc);
Fim.
Fim Algoritmo


05
A mãe deJoão tem 80 anos. Em que ano ela nasceu?
Algoritmo Idade_Mae_Joao
Declare
Int 80, ano_atual, ano_nasc;
Iniciar
Escreva (“Digite o ano atual”);
Leia(ano_atual);
ano_nasc = ano_atual-80;
Escreva (“O ano de nascimento eh: ”, ano_nasc);
Fim.
Fim Algoritmo

06
O pai de João tem X anos. Em que ano ela nasceu?
Algoritmo Idade_Pai_Joao
Declare
Int idade, ano_atual, ano_nasc;Iniciar
Escreva (“Digite quantos anos ele tem”);
Leia(idade);
Escreva (“Digite o ano atual”);
Leia(ano_atual);
ano_nasc = ano_atual-idade;
Escreva (“O ano de nascimento eh: ”, ano_nasc);
Fim.
Fim Algoritmo

07
O pai de João tem X anos. Em que ano ela nasceu e qual ano ele fez 50 anos?
Algoritmo Idade_Pai_Joao_02
Declare
Int idade, ano_atual=0, ano_nasc=0, ano_50=0;Iniciar
Escreva (“Digite quantos anos ele tem”);
Leia(idade);
Escreva (“Digite o ano atual”);
Leia(ano_atual);
ano_nasc = ano_atual-idade;
ano_50 = ano_nasc+50;
Escreva (“O ano de nascimento eh: ”, ano_nasc);
Escreva (“O ano de nascimento eh: ”, ano_50);
Fim.
Fim Algoritmo

08
Faça um algoritmo que calcule o preço de 04 produtos e descubra a média de preço.Algoritmo Media_De_Preco
Declare
Real media_preco, preco_01, preco_02, preco_03, preco_04;
Iniciar
Escreva (“Digite o preço 01”);
Leia(preco_01);
Escreva (“Digite o preço 02”);
Leia(preco_02);
Escreva (“Digite o preço 03”);
Leia(preco_03);
Escreva (“Digite o preço 04”);
Leia(preco_04);
media_preco = (preco_01+ preco_02+ preco_03+ preco_04)/4;
Escreva (“A médiadas idades é: ”,media_preco);
Fim.
Fim Algoritmo

Lista de exercício com Condicionais

Faça um algoritmo que solicite a idade de um usuário. Se a idade for maior ou igual a 18 escreva: MAIORIDADE senão VOCÊ AINDA NÃO ATINGU A MAIORIDADE.
Algoritmo maioridade_menor_idade
Declare
int idade=0;
Iniciar
//bloco de solicitação ao usuário
escreva(“Digite sua idade”);leia(idade);

//iniciando o bloco de verificação da idade
se(idade>=18)então
inicio
escreva(“MAIORIDADE”);
fim se
senao
inicio
escreva(“VOCÊ AINDA NÃO ATINGU A MAIORIDADE”);
fim senao
Fim.
Fim Algoritmo

Faça um algoritmo que solicite a idade de um usuário e o ano atual. Se a idade for maior ou igual a 18 escreva: MAIORIDADE e mostre seu ano de nascimento senão VOCÊ AINDA...
Ler documento completo

Por favor, assinar para o acesso.

Estes textos também podem ser interessantes

  • Algoritmo
  • Algoritmo
  • Algoritmos
  • Algoritmo
  • Algoritmo
  • Algoritmo
  • Algoritmo
  • Algoritmos

Seja um membro do Trabalhos Feitos

CADASTRE-SE AGORA!