algoritmo lista vetor e matriz

Páginas: 5 (1025 palavras) Publicado: 18 de maio de 2015
Lista Vetor e Matriz
Aluno: Matheus Mota Leonis - UC14100761

algoritmo "Exercício 1"
// Função :
// Autor :Matheus Mota Leonis
// Data : 14/05/2015
// Seção de Declarações
var
i:inteiro
nome:Vetor [1..10]de caracter
inicio
// Seção de Comandos
para i de 1 ate 10 passo 1 faca
Escreva ("Digite o",i,"º nome:")
leia (nome[i])
fimpara
limpatela
Escreval ("Nomes informados")
escreval
para i de 1ate 10 passo 1 faca
Escreval ("Nome[",i:1,"]:",nome[i])
fimpara
fimalgoritmo


algoritmo "Exercicio 2"
// Função :
// Autor :Matheus Mota Leonis
// Data : 14/05/2015
// Seção de Declarações
var
i,j:inteiro
salario:Vetor [1..15,1..2]de real
inicio
// Seção de Comandos
para i de 1 ate 15 passo 1 faca
para j de 1 ate 1 passo 1 faca
Escreva ("Digite o salário do ",i,"º funcionário:")
leia(salario[i,j])
fimpara
fimpara
limpatela
Escreval ("Salários Reajustado")
escreval
para i de 1 ate 15 passo 1 faca
salario[i,2]<- salario[i,1]*1.08
Escreval (salario[i,1]:2:2,salario[i,2]:13:2)
fimpara
fimalgoritmo












algoritmo "Exercício 3"
// Função :
// Autor :Matheus Mota Leonis
// Data : 14/05/2015
// Seção de Declarações
var
i,lim_sup:inteiro
nome:vetor[1..100]de caracter
idade:vetor[1..100]deinteiro
inicio
// Seção de Comandos
Escreva ("Digite o número de pessoas ao qual será perguntado nome e idade:")
leia (lim_sup)
Escreval
para i de 1 ate lim_sup passo 1 faca
Escreva ("Digite o",i,"º nome:")
leia (nome[i])
Escreva ("Digite a ",i,"ª idade:")
leia (idade[i])
escreval
fimpara
limpatela
Escreval ("NOME":31,"IDADE")
escreval
para i de 1 ate lim_sup passo 1 faca
Escreval("Nome[",i:3,"]:",nome[i]:15,"idade[",i:3,"]:",idade[i]:1)
fimpara
fimalgoritmo


algoritmo "Exercício 4"
// Função :
// Autor :Matheus Mota Leonis
// Data : 14/05/2015
// Seção de Declarações
var
i:inteiro
cliente: vetor[1..60] de real
inicio
// Seção de Comandos
para i de 1 ate 60 passo 1 faca
Escreva ("Digite o valor de compra do",i:3,"ºcliente:")
leia (cliente[i])
fimpara
limpatela
para i de 1 ate 60passo 1 faca
Escreva ("Valor total da compra do cliente[",i:2,"]:",cliente[i]:2:2)
se cliente[i] >= 500 entao
Escreval (" [Desconto de 15% concedido]")
cliente[i] <- (cliente[i]*0.85)
senao
escreval ("[Desconto não concedido]")
fimse
Escreval ("Valor a ser pago pelo cliente[",i:2,"]:",cliente[i]:2:2)
escreval
fimpara
fimalgoritmo






algoritmo "Exercício 5"
// Função :
// Autor :Matheus Mota Leonis// Data : 15/05/2015
// Seção de Declarações
var
i,j: inteiro
numero:vetor [1..4,1..4] de real
inicio
// Seção de Comandos
para i de 1 ate 4 passo 1 faca
para j de 1 ate 4 passo 1 faca
escreva ("Digite o valor da posição [",i:1,",",j:1,"]:")
leia (numero[i,j])
fimpara
fimpara
limpatela
para i de 1 ate 4 passo 1 faca
para j de 1 ate 4 passo 1 faca
escreva(numero[i,j]:4)
fimpara
escreval
fimparafimalgoritmo

algoritmo "Exercício 6"
// Função :
// Autor :Matheus Mota Leonis
// Data : 15/05/2015
// Seção de Declarações
var
i,j: inteiro
numero:vetor [1..4,1..4] de real
inicio
// Seção de Comandos
para i de 1 ate 3 passo 1 faca
para j de 1 ate 3 passo 1 faca
escreva ("Digite o valor da posição [",i:1,",",j:1,"]:")
leia (numero[i,j])
fimpara
fimpara
escreval
limpatela
para i de 1 ate 3 passo1 faca
escreva ("[linha",i,"]->")
para j de 1 ate 3 passo 1 faca
escreva(numero[i,j]:4)
fimpara
escreval
fimpara
escreval
para i de 1 ate 3 passo 1 faca
escreva ("[linha",4-i,"]->")
para j de 1 ate 3 passo 1 faca
escreva (numero[4-i,j]:4)
fimpara
escreval
fimpara
fimalgoritmo




algoritmo "Exercício 7"
// Função :
// Autor :Matheus Mota Leonis
// Data : 15/05/2015
// Seção de Declarações
vari,j: inteiro
numero:vetor [1..3,1..5] de real
acum: real
inicio
// Seção de Comandos
para i de 1 ate 3 passo 1 faca
para j de 1 ate 5 passo 1 faca
escreva ("Digite o valor da posição [",i:1,",",j:1,"]:")
leia (numero[i,j])
fimpara
fimpara
escreval
limpatela
para i de 1 ate 3 passo 1 faca
para j de 1 ate 5 passo 1 faca
escreva(numero[i,j]:4)
acum <- acum+numero[i,j]
fimpara
escreval
fimpara...
Ler documento completo

Por favor, assinar para o acesso.

Estes textos também podem ser interessantes

  • Algoritmo vetor/matriz
  • Matriz Unidimensional
  • vetor e matriz
  • matriz e vetores
  • Matriz e vetor
  • matriz e vetor
  • matriz e vetor
  • Vetores em algoritmo

Seja um membro do Trabalhos Feitos

CADASTRE-SE AGORA!