Algoritmo - lógica de programação

Páginas: 2 (473 palavras) Publicado: 1 de outubro de 2012
1 - Faça um programa que receba 3 números, calcule e mostre a multiplicação desses números.

Algoritmo
declare
n1, n2, n3, m numérico;
leia n1, n2, n3;
m ← (n1 * n2 * n3);
escreva “o valor damultiplicação é:”, m;
fim_algoritmo;

2 - Faça um programa que receba o preço de um produto, calcule e mostre o novo preço, sabendo que este sofreu um desconto de 10%.

Algoritmo
declare
p, d,pd numérico;
d ← 10%;
leia p;
pd ← (p -( p * 0,1);
escreva “o valor do produto com desconto é:”, pd;
fim_algoritmo;

3 - Faça um programa que recebe os valores dos catetos de um triângulo,calcule e imprima o valor da hipotenusa.

Algoritmo:
declare:
a, b, h, r numérico;

leia a, b;
h ← ((a^2)+(b^2));
escreva(“o valor da hipotenusa é:”,h);
r ← Raizq(h);
escreva(“O valor daraiz quadrada é:”, r);
fim_algoritmo;

4 - Faça um programa que calcule e mostre a tabuada da adição, de um número recebido pelo usuário.

algoritmo;
declare;
v, c :numérico;
leia (v,c);
para c← 1 até 10 faça;
escreva (v, ' x ', c, ' = ', (v * c));
fimpara;
fim_algoritmo;

Estrutura condicional.
5 - Faça um programa que receba 2 valores e imprima o menor deles.

Algoritmodeclare
v1, v2, numérico;

leia a, b;
se (v1>v2) então
escreva “o menor valor é:”, v2;
senão
escreva “o menor valor é:”, v1;
fim_algoritmo;

6 - Faça um algoritmo que leia dois números eidentifique se são iguais ou diferentes. Caso
eles sejam iguais, imprima uma mensagem dizendo eles são iguais. Caso seja diferente, imprima que é o maior e uma mensagem dizendo que são diferentes.algoritmo
declare
n1, n2 numérico;
leia n1,n2;
Se (n1 = n2) então
escreva “os números são iguais”;
senão
inicio
se (n1 > n2) então;
escreva "O número",n1," é maior que o número",n2;
escreva"Eles são diferentes";
senão
escreva "O número",2," é maior que o número",n1);
escreva "Eles são diferentes";
fim
fim_algoritmo;


7 - Faça um programa para calcular e mostra o valor...
Ler documento completo

Por favor, assinar para o acesso.

Estes textos também podem ser interessantes

  • Algoritmos e Lógica de Programação
  • Algoritmos e Lógica de Programação
  • Algoritmos e Logica de Programacao
  • ALGORITMOS E LÓGICA DE PROGRAMAÇÃO Exercícios
  • Introdução a algoritmos e lógica de programaçao
  • Logica de programação e algoritmos
  • Algoritmos e logica de programação
  • Algoritmo e Lógica de Programação

Seja um membro do Trabalhos Feitos

CADASTRE-SE AGORA!