algoritimo sequiecial e repeticao

Páginas: 6 (1347 palavras) Publicado: 7 de outubro de 2014
TRABALHO 2 – Estrutura de Repetição.

Aluno : jhonatan alan silva de antonio >>> eng civil turma c


1) Escreva um algoritmo em pseudocódigo que mostre os números pares de 1 a 1000.


algoritmo "semnome"
// Função :
// Autor : jhonatan alan silva de antonio
// Data : 22/09/2014
// Seção de Declarações
var
i:inteiro
inicio
// Seção de Comandos
para i de 1 ate 1000 facase (i % 2 = 0) entao
escreval (i:5)
fimse
fimpara
fimalgoritmo


2) Escreva um algoritmo em pseudocódigo que mostre os números ímpares de 1 a 1000.


algoritmo "semnome"
// Função :
// Autor : jhonatan alan silva de antonio
// Data : 22/09/2014
// Seção de Declarações
var
i:inteiro
inicio
// Seção de Comandos
para i de 1 ate 1000 faca
se (i % 2 = 1) entao
escreval (i:5)fimse
fimpara
fimalgoritmo


3) Escreva um algoritmo em pseudocódigo que mostre os múltiplos de 8 de 1 a 1000 algoritmo

"semnome"
// Função :
// Autor : jhonatan alan silva de antonio
// Data : 22/09/2014
// Seção de Declarações
var
i:inteiro
inicio
// Seção de Comandos
para i de 1 ate 1000 faca
se (i % 8 = 0) entao
escreval (i:5)
fimse
fimpara
fimalgoritmo4) Escreva um algoritmo em pseudocódigo que leia 50 números, calcule e mostre a média aritmética, o
maior e menor número.

algoritmo "semnome"
// Função :
// Autor : jhonatan alan silva de antonio
// Data : 22/09/2014
// Seção de Declarações
var
contador:inteiro
numero, maior_num, menor_num, somador:real
inicio
// Seção de Comandos
escreval ("Digite um número --> ")
leia(numero)
para contador de 2 ate 50 faca
escreval ("Digite um número --> ")
leia (numero)
somador:=somador+numero
se ( maior_num < numero ) entao
maior_num:=numero
fimse
se ( menor_num > numero ) entao
menor_num:=numero
fimse
fimpara
escreval (maior_num, menor_num, somador/50)
fimalgoritmo


5) Crie um algoritmo em pseudocódigo que leia um número que seráo limite de um intervalo e imprima
todos os números impares menores que esse número. Exemplo:
Limite Superior: 16
Saída: 1, 3, 5, 7, 9, 11, 13, 15


algoritmo "semnome"
// Função :
// Autor : jhonatan alan silva de antonio
// Data : 22/09/2014
// Seção de Declarações
var
limite, i:inteiro
inicio
// Seção de Comandos
escreval ("Digite o valor de Limite do intervalo --> ")
leia(limite)
para i de 1 ate limite faca
se (i%2=1) entao
escreval (i)
fimse
fimpara
fimalgoritmo

6) Crie um algoritmo em pseudocódigo que leia um número que será o limite de um intervalo e imprima
todos os números pares menores que esse número. Exemplo:
Limite Superior: 10
Saída: 2,4,6,8



algoritmo "semnome"
// Função :
// Autor : jhonatan alan silva de antonio
//Data : 22/09/2014
// Seção de Declarações
var
limite, i:inteiro
inicio
// Seção de Comandos
escreval ("Digite o valor de Limite do intervalo --> ")
leia (limite)
para i de 1 ate limite faca
se (i%2=0) entao
escreval (i)
fimse
fimpara
fimalgoritmo


7) Crie um algoritmo que leia vários números inteiros e positivos e imprima a média aritmética dos
números múltiplos de3 e múltiplos de 5. Digite zero para sair.


algoritmo "semnome"
// Função :
// Autor : jhonatan alan silva de antonio
// Data : 22/09/2014
// Seção de Declarações
var
numero, i, valor:inteiro
MA:real
inicio
// Seção de Comandos
repita
escreval ("Digite um valor")
leia (valor)
se ( valor = 0 ) entao
interrompa
fimse
para i de 3 ate 50 faca
se (i % 3= 0) entao
escreval (i:5)
escreval
MA:=(i/50)
escreval ("A média ->", MA )
fimse
fimpara
escreval
para i de 5 ate 50 faca
se (i % 5 = 0) entao
escreval (i:5)
escreval
MA:=(i/50)
escreval ("A média ->", MA )
fimse
fimpara
ate ( valor = 0 )
fimalgoritmo


8) Faça um algoritmo em...
Ler documento completo

Por favor, assinar para o acesso.

Estes textos também podem ser interessantes

  • Algoritimos Sistemas de repetição
  • Repetição
  • Repetição
  • Repetição
  • Repeticao
  • repetição
  • Repeticão
  • algoritimo

Seja um membro do Trabalhos Feitos

CADASTRE-SE AGORA!