Trabalho visual alg

Disponível somente no TrabalhosFeitos
  • Páginas : 5 (1068 palavras )
  • Download(s) : 0
  • Publicado : 8 de maio de 2012
Ler documento completo
Amostra do texto
1 INTRODUÇÃO

Este trabalho tem como objetivo aperfeiçoar o conhecimento sobre a linguagem VisuAlg, que é uma versão portuguesa dos pseudocódigos largamente utilizados nos livros de introdução à programação, conhecida como "Portugol". A linguagem do VisuAlg permite apenas um comando por linha: desse modo, não há necessidade de tokens separadores de estruturas. Também não existe o conceito deblocos de comandos, nem comandos de desvio incondicional. Na versão atual do VisuAlg, com exceção das rotinas de entrada e saída, não há nenhum subprograma embutido.
Na primeira parte do trabalho, teremos que desenvolver os quatro primeiros exercícios utilizando o visualg. O quinto exercício pode ser desenvolvido de forma integral ou através da representação de um código com a documentação de seufuncionamento (o programa deverá ser comentado para que seja possível analisar a forma como foi realizada a conversão).
Na segunda parte, traduziremos o conceito de Fundamentos da Administração da Informação e construiremos a respectiva tabela-verdade

2 DESENVOLVIMENTO

2.1 PARTE I - Questão 01

algoritmo "Cálculo Consumo Médio"
// Autor: Rafael Bomfim
// Data: 31/05/2011
var
a, x:caracter
cm, dist, vol: real
inicio
repita
limpatela
escreval ("Algoritmo para calcular o consumo")
escreval ("Distância total percorrida (Km):")
leia (dist)
escreval ("Volume de combustível gasto (L):")
leia (vol)
cm <- dist/vol
escreval ("Consumo médio=", cm, " Km/l")
escreval ("Aperte ENTER para Calcular outro Consumo Médio ou 'S' para SAIR")
x<- " "
leia (a)
ate a= "s"fimalgoritmo

Questão 02

algoritmo "Cálculo Salário Líquido do Funcionário"
// Autor: Rafael Bomfim
// Data: 30/05/2011
var
a, x, nome: caracter
salbruto: real
inss: real
saldesc: real
inicio
repita
limpatela
escreval ("Digite o nome do funcionário:")
leia (nome)
escreval ("Digite o valor do salário:")
leia (salbruto)
se salbruto >= 1000 entao
inss <- 0.11 *salbruto
saldesc <- salbruto - inss
senao
inss <- 0.09 * salbruto
saldesc <- salbruto - inss
fimse
escreval ("O Nome do Funcionário é: ", nome)
escreval ("O Salário Bruto é: ", salbruto)
escreval ("O Desconto do INSS é: ", inss)
escreval ("O Salário Líquido é: ", saldesc)
escreval ("Aperte ENTER para Calcular outro Salário ou 'S' para SAIR")x<- " "
leia(a)
ate a= "s"
fimalgoritmo

Questão 03

algoritmo "Valor do Desconto"
// Autor: Rafael Bomfim
// Data: 31/05/2011
var
a, x, nome: caracter
compra: real
desc: real
inicio
repita
limpatela
escreval ("Digite o nome do cliente")
leia (nome)
escreval ("Digite o valor da compra")
leia (compra)
se compra <= 1000 entao
desc <- 0.05 * compra
senaose compra >= 1000 e compra <= 5000 entao
desc <- 0.10 * compra
senao
se compra >= 5000 entao
desc <- 0.15 * compra
fimse
fimse
fimse
escreval ("O Nome do Cliente é R$ ", nome)
escreval ("O valor da Compra é R$ ", compra)
escreval ("O Valor do Desconto é R$ ", desc)
escreval ("Aperte ENTER para Calcular outro Desconto ou 'S'para SAIR")
x<- " "
leia(a)
ate a= "s"
fimalgoritmo

Questão 04

algoritmo "Média Turma"
// Autor: Rafael Bomfim
// Data: 31/05/2011
var
alunos: vetor[1..5] de caracter
notas1: vetor[1..5] de real
notas2: vetor[1..5] de real
media, mediageral: real
aprovado, reprovado, recuperacao, i: inteiro
inicio
aprovado <- 0
reprovado <- 0
recuperacao <- 0
para i de 1 ate 5faca
escreva ("Qual Nome do Aluno.: ")
leia (alunos[i])
escreva ("Insira Nota 1: ")
leia (notas1[i])
escreva ("Insira Nota 2: ")
leia (notas2[i])
media <- ( (notas1[i] + notas2[i]) / 2 )
se media >= 7 entao
escreval ("Aluno(a) APROVADO: ", alunos[i])
escreval ("Média final......: ", media)
aprovado <- aprovado +...
tracking img