Trabalho sobre algoitimos

Disponível somente no TrabalhosFeitos
  • Páginas : 2 (420 palavras )
  • Download(s) : 0
  • Publicado : 17 de outubro de 2012
Ler documento completo
Amostra do texto
Respostas da atividade de informática:
Questão 1:
Linguagem natural: Os algoritmos são expressos diretamente em linguagem normal, sempre no imperativo.
Fluxograma: Neste tipo de representação, osalgoritmos se apresentam de forma gráfica, usando figuras geométricas para indicar as ações e decisões que devem ser executadas.
Pseudo-linguagem: trata-se de uma linguagem intermediária entre alinguagem natural e uma linguagem e programação para descrever os algoritmos.
Exemplo de algoritmo nas três de formas de representação:
Algoritmo para calcular imc.
Em linguagem natural:
1-Informe o seu peso
2- informe a sua altura ao quadrado
3- Divida o seu peso pelo quadrado da sua altura
4- Exiba o seu imc.

Em fluxograma:
Início
Início

FIM
FIM
IMC
IMC
IMC= peso/ (altura)²
-

IMC= peso / (altura)²
-

Peso, altura
Peso, altura

Em pseudo-linguagem:
Algoritmo “CalcularIMC”

Var: peso, altura, IMC

Início
Imprima (“Digite seupeso”)
Ler (peso)
Imprima (“Digite sua altura”)
Ler (altura)
IMC<- peso/altura^2
Imprima IMC

Fim.
Questão 2
Algoritmo 1
Inicio
repita
escreval ("Qual foi sua A1 ?")
leia (a)
escreval("Qual foi sua A2 ?")
leia (b)
escreval ("Qual foi sua A3 ?")
leia (c)
d <- a*5+b*6+c*7
k <- d/18
escreval (k)
escreval ("Para parar o programa, digite, 999.")
leia (o)
se o = 999 entaointerrompa
fimse
fimrepita
fimalgoritmo

algoritimo2

"primo"
var
i,num,cont:inteiro
inicio
escreval("escreva numero")
leia(num)
cont<-0
i<-0
Para i de 1 ate(num) faca
se((num%i)=0)entao
cont<-cont+1
fimse
fimpara

se(cont=2)entao
escreval("é primo")senao
escreval("nao é primo")
fimse
fimalgoritmo

algoritmo 3
"aprovados_reprovados"
var
media:real
ap,rp,i,al:inteiro
inicio...
tracking img