Trabalho em grupo

Disponível somente no TrabalhosFeitos
  • Páginas : 6 (1363 palavras )
  • Download(s) : 0
  • Publicado : 15 de novembro de 2012
Ler documento completo
Amostra do texto
Sistema de Ensino Presencial Conectado
analise e desenvolvimento de sistemas

TRABALHO EM GRUPO 3º SEMESTRE

Araranguá
2012

TRABALHO EM GRUPO 3º SEMESTRE

Trabalho de Análise e Desenvolvimento de Sistemas apresentado à Universidade Norte do Paraná - UNOPAR, como requisito parcial para a obtenção de média bimestral na disciplina de Análise de Sistemas II, Desenvolvimento Orientado aObjeto I, Banco de Dados II e Algoritmos e Estrutura de Dados.

Orientador: Polyanna P. Gomes Fabris, Marcio Chiaveli, Roberto Nishimura e Merris Mozer.

Araranguá
2012

SUMÁRIO
1 INTRODUÇÃO 3

2 DESENVOLVIMENTO 4
2.1 Diagrama de Atividade ..........................................................................................4
2.2 Diagrama Entidade Relacionamento.MRN............................................................4

2.3 Lista do Tipo Fila ...................................................................................................5

2.4 Mapeamento Orientado Objeto.............................................................................6

Conclusão..................................................................................................................20

Referencias ...............................................................................................................21
INTRODUÇÃO
Neste portfólio estaremos abordando sobre diagramas de atividades, diagrama entidade relacionamento MRN, lista tipo fila e mapeamento orientado objeto, utilizando como cenário um locadora de livros em duas situações.

DESENVOLVIMENTO2.1- Diagrama de atividade.

2.2- Diagrama Entidade e Relacionamento, aplicando o processo MRN.

2.3- Utilizando a ferramenta visualg criamos uma lista do tipo fila ordenada pela data.

Algoritmo "fila"
Var
vdia: vetor[1..5] de inteiro
I, J : inteiro
iaux : inteiro
saux :caracter
scliente :vetor[1..5] de caracter
Inicio

Para I de 1 ate 5 facaEscreva("Conta - ",I," Informe o nome do cliente : ")
Leia(scliente[I])
Escreva("Conta - ",I," Informe a data do Emprestimo AnoMesvdia (AAAAmmDD) : ")
Leia(vdia[I])
Escreval (" ")
Fimpara
Para J de 2 ate 5 faca
iaux <- vdia[j]
saux <- scliente[j]
I <- J - 1
Enquanto (I > 0) E(vdia[I] > iaux) faca
vdia[I + 1] <- vdia[I]
scliente[I + 1] <- scliente[I]
I <- I - 1
se (I = 0) entao
INTERROMPA
Fimse
Fimenquanto
vdia[I + 1] <- iaux
scliente[I + 1] <- saux
Fimpara
Escreval("VetorOrdenado pela data de Locaçao do livro: ")
Escreval(" ")
Escreval("Inicio da Fila")
Escreval(" ")
Para I de 1 ate 5 faca
Escreval(scliente[I])
Escreval(vdia[I])
Fimpara
Escreval(" ")
Escreval("Fim da Fila")

Fimalgoritmo

2.4- Mapeamento orientado objeto

using System;
using System.Collections.Generic;
usingSystem.Linq;
using System.Text;

namespace portifolio
{
class cliente
{
private int codigo;
private string nome;
private int codigo_cidade;
private string endereco;
private string numero;
private int codigo_bairro;
private string telefone;
private double debito;
private DateTime data_nascimento;
private intcodigo_status;

public int codigo
{
get { return codigo; }
set { codigo = value; }
}

public string nome
{
get { return nome; }
set { nome = value; }
}

public int codigo_cidade
{
get { return codigo_cidade; }
set { codigo_cidade = value; }
}...
tracking img