Trabalho de algoritimo

Disponível somente no TrabalhosFeitos
  • Páginas : 5 (1128 palavras )
  • Download(s) : 0
  • Publicado : 5 de julho de 2012
Ler documento completo
Amostra do texto
UNIVERSIDADE FEDERAL DO AMAZONAS
INSTITUTO DE CIÊNCIAS EXATAS

TRABALHO DE CÁLCULO NUMÉRICO

MANAUS, 08 DE SETEMBRO DE 2009
UNIVERSIDADE FEDERAL DO AMAZONAS
INSTITUTO DE CIÊNCIAS EXATAS

TRABALHO DE CÁLCULO NUMÉRICO

Trabalho solicitado pelo professor Alberto Vilaça as alunas Alana Patrícia MotaPereira e Sabrina de Oliveira com a finalidade de treinar seus conhecimentos em algoritmo.

MANAUS, 08 DE SETEMBRO DE 2009
UNIVERSIDADE FEDERAL DO AMAZONAS

Índice

Introdução _________________________________________________ 04
Exercícios _________________________________________________ 05
Conclusão __________________________________________________Bibliografia__________________________________________________

UNIVERSIDADE FEDERAL DO AMAZONAS

Introdução

Desenvolveremos a construção dos algoritmos solicitados pelo professor e após o término do trabalho inscrito será feita a defesa de algum dos algoritmos por nós, sendo este escolhido pelo professor.

UNIVERSIDADE FEDERAL DO AMAZONAS

Exercícios

1°. A série de Fibonacci é formada pela seguinte seguência:1,1,2,3,5,8,13,21,34,...etc. Escreva um algoritmo que gera esta seguencia até o décimo termo.
algoritmo "Sequência de Fibonacc"
// Função : Determinar os termos da sequência
var
A,B,C:Real
n,i:inteiro
inicio
A<-1
B<-1
C<-0
escreval ("Qual o Número de Termos?")
leia ( n )
para i<-1 ate n passo 1 faca
C<-A+B
escreva (A)
A<-B
B<-C
fimpara
fimalgoritmo

2°.Sendo H= 1+1/2+1/3+1/4+…+1/N, prepare um algoritmo para entrar o número H o número N é fornecido pelo usuário.
algoritmo "entrar H"
objetivo: fazer um algoritmo para a entrada de um numero H sendo fornecido um numero N pelo usuario
var
H: Real
n,i:Inteiro
inicio
H<-0
leia (n)
para i<-1 ate n passo 1 faca
H<-H+1/i
fimpara
escreva (H)
fimalgoritmo

3°. Elabore um algoritmoque determine o valor de S, onde: S= 1/1-1/2+3/9-4/9+5/25-6/36+...-10/100.
algoritmo "Valor de S"
objetivo:calcular o valor de S
var
S,H:Real
n,i: Inteiro
inicio
H<-0
leia (n)
para i<-1 ate n passo 1 faca
H<-H+(-1)^(i+1)*(1/i)
fimpara
escreva(H)
fimalgoritmo

4°. Escreva um algoritmo que calcule a soma dos dez primeiros termos da seguinte serie: 2/500-5/450+2/400-5/350+…algoritmo "somardez primeiros"
// Função : calcular a soma dos dez primeiros termos da seguencia.
var
S,A: Real
n,i: Inteiro
inicio
A<-0
leia (n)
para i<-1 ate n-5 passo 1 faca
A<-A+2/(500-100*(i-1))-5/(450-100*(i-1))
fimpara
S<-A
escreva (S)
fimalgoritmo

5°. Elabore um algoritmo que calcule N! sendo que o valor inteiro de N é fornecido pelo usuário.
algoritmo "Nfatorial"
// Função :calcular o valor de N fatorial
var
p,n,i:Inteiro
inicio
leia (n)
p<-n
para i<-1 ate n-1 passo 1 faca
p<-p*(n-i)
fimpara
escreva (p)
fimalgoritmo

6°. Construa um algoritmo que calcule o valor aproximado de PI utilizando a fórmula π= 3√(H*32), onde : H=(1/1)³+(1/5)³-(1/7)³+(1/9)³-..., vai até o décimo termo.
algoritmo "valor PI"
// Função :algoritmo quecalcula o valor de PI a partir da formula
var
p,h,d:Real
n,i:Inteiro
inicio
leia (n)
h<-0
para i<-1 ate n passo 1 faca
h<-h+((-1)^(i+1)*(1/(2*i-1)))^3
fimpara
p<-3*(1.131*h)^(1/2)
escreva (p)
fimalgoritmo

7°. Faça um algoritmo para calcular a norma² ou norma euclidiana de um vetor x de tamanho n, definida por: ||x||= √Σ(xi)².
algoritmo "calculonorma"
// Função :calcular anorma euclidiana definida pela funçao
var
norma, x,y,z:Real
inicio
leia (x,y,z)
norma<-(((x^2)^(1/2))^2+((y^2)^(1/2))^2+((z^2)^(1/2))^2)^1/2
escreva (norma)
fimalgoritmo

8°. Propor um algoritmo que faça o uso de uma estrutura de repetição com um número indefinido de repetições.
algoritmo "repetiçao"
// Função :fazer uma estrutura de repetição com um numero indefinido.
var...
tracking img