Trabalho Algoritmo

Disponível somente no TrabalhosFeitos
  • Páginas : 2 (362 palavras )
  • Download(s) : 0
  • Publicado : 29 de setembro de 2014
Ler documento completo
Amostra do texto
1- Entrar com um número e imprimi-lo caso seja maior que 20.

Inicio
Inteiro: num
imprimir (“Digite o número: ”);
ler (num);
se (num > 20) então
imprimir (“Valor donúmero é: ”, num);
fimse
Fim

2- Construir um algoritmo que leia dois valores numéricos e efetue a adição; caso o resultado seja maior que 10, apresenta-lo.

Inicio
Inteiro: num1, num2,soma
imprimir (“Digite o primeiro número: ”);
ler (num1);
imprimir (“Digite o segundo número: ”);
ler (num2);
soma  (num1 + num2);
se (soma > 10) entãoimprimir (“A soma dos valores é: ”, soma);
fimse
Fim

3- Construir um algoritmo que leia dois números e efetue a adição. Caso o valor somado seja maior que 20, este deverá ser apresentadosomando-se a ele mais 8; caso o valor somado seja menor ou igual a 20, este deverá ser apresentado subtraindo-se 5.

Inicio
inteiro: num1, num2, soma
imprimir (“Digite o primeiro número: ”);ler (num1);
imprimir (“Digite o segundo número: ”);
ler (num2);
soma  (num1 + num2);
se (soma > 20) então
imprimir (“O resultado da operação é: ”, soma + 8);senão
imprimir (“O resultado da operação é: ”, sub - 5);
fimse
Fim



4- Entrar com um número e imprimir uma das mensagens: é múltiplo de 3 ou não é múltiplo de 3.Inicio
inteiro: num, resto
imprimir (“Digite o número: ”);
ler (num);
resto  (num mod 3);
se (resto = 0) então
imprimir (num, “ é múltiplo de 3.”);
senãoimprimir (num, “ não é múltiplo de 3.”);
fimse
Fim

5- Entrar com um número e informar se ele é divisível por 10, por 5, por 2 ou se não é divisível por nenhum destes.

iniciovar
inteiro: num, resto10, resto5, resto2

escreva("Entre com um valor ")
leia(num)
resto10= C ou não A = 3.5 ou não 2 = 3.5 ou não V
F e F ou F
F ou F...
tracking img