Raciocinio

Disponível somente no TrabalhosFeitos
  • Páginas : 2 (398 palavras )
  • Download(s) : 0
  • Publicado : 20 de março de 2013
Ler documento completo
Amostra do texto
Prova de Algoritmo
Professor: Alessandro Souza

1. O que é algoritmo e quais as formas de representa-lo foram vista em nosso curso?
Resposta: É uma linguagem de computador “lógica”
Ondepoderá ser representada das seguintes maneiras com:
Fluxograma, pseudocódigo, descrição narrativa.

2. Faça um PASCAL calcule e imprima a soma dos números pares e a quantidade de números imparesexistentes em um vetor de 10 posições.
Resposta:
algoritmo "Quantidade de Pares e Impares"
// Função :
// Autor :
// Data : 04/03/2013
// Seção de Declarações
var
i, impar,soma_par : inteironum : vetor[0..10] de inteiro
inicio

soma_par <- 0
impar <- 0
escreval("Digite Dez Numeros ")
para i de 1 ate 10 faca
escreval("Numero: ", i)leia (num[i])
se num[i] mod 2 = 0 entao
soma_par <- soma_par+num[i] senao
senao
impar <- impar + 1
fimse
fimparaescreval ("A soma dos numeros pares ", soma_par)
para i de 1 ate 10 faca
se num[i] mod 2 = 0 entao
escreval(num[i])
fimse
fimparaescreval("Os Numeros Impares São: ")
para i de 1 ate 10 faca
se num[i] mod 2 > 0 entao
escreval(num[i])
fimse
fimpara
fimalgoritmo

3. Facaum algoritmo que leia o valor do salario de um funcionário e aplique o seguinte aumento
Se o funcionário ganhar mais de 1000,00 aplique um aumento de 10%
Se o funcionário ganhar entre 500,00 e1000,00 aplique um aumento de 15%
Se o funcionário ganhar menos de 500,00 aplique um aumento de 20%
algoritmo "questao .3"
// Função :
// Autor :
// Data : 11/03/2013
// Seção de Declarações
varsalario, salarionovo : real
inicio
// Seção de Comandos
escreval("Digite o Salario Atual do Funcionario: ")
leia(salario)
se salario > 1000 entao
salarionovo <-...
tracking img