Programação

Disponível somente no TrabalhosFeitos
  • Páginas : 2 (304 palavras )
  • Download(s) : 0
  • Publicado : 4 de março de 2013
Ler documento completo
Amostra do texto
Computação/Informática Básica

7. Estrutura de Decisão
Neste tipo de estrutura o fluxo de instruções a ser seguido é escolhido em função do resultado da avaliação de uma ou mais condições. Umacondição é uma expressão lógica. A classificação das estruturas de decisão é feita de acordo com o número de condições que devem ser testadas para que se decida qual o caminho a ser seguido. Têm-se2 tipos de estrutura de decisão: • Se; • Escolha. Em linguagem C, o equivalente ao Se é a função if() e o equivalente ao Escolha é a função switch().

7.1. if()
Nesta estrutura uma únicacondição (expressão lógica) é avaliada. Se o resultado desta avaliação for verdadeiro (.V.), então um determinado conjunto de instruções (comandos compostos) é executado. Caso contrário, ou seja, quando oresultado da avaliação for falso (.F.), nada é executado e o fluxo de execução segue para o primeiro comando após o fim da estrutura. Fluxograma

Pseudocódigo Se (condição) Então Comando 1;Fim_Se Linguagem C if (condição) { Comando 1; }

36

Computação/Informática Básica

Exemplo 1: Fluxograma Algoritmo Algoritmo Exemplo1; Var a: inteiro; Inicio Escreva (“Entre com o valor de A:”); Leia (a); Se (a50000) { printf("Voce ganha bem.\n"); } else { printf("Voce precisa ganhar mais.\n"); } }

39

Computação/Informática Básica

7.3. Encadeamento de if()
Trata-se de um recursoque permite ao usuário utilizar uma estrutura if dentro de outra obtendo, assim, diversas respostas possíveis. Exemplo 3: Fluxograma

Pseudocódigo Algoritmo Encadeamento; Var num: inteiro;Inicio Escreva (“Entre com um número: ”); Leia (num); Se (num = 0) Então Escreva (“Número zero.”); Senão Se ( num < 0) Então Escreva (“Número negativo.”); Senão Escreva (“Número positivo.”); Fim_SeFim_Se Fim

40

Computação/Informática Básica

Linguagem C #include main() { int num; printf("Entre com um numero: "); scanf("%d",&num); if(num == 0) { printf("Numero zero.\n"); } else {...
tracking img