Programação estruturada

Disponível somente no TrabalhosFeitos
  • Páginas : 7 (1656 palavras )
  • Download(s) : 0
  • Publicado : 30 de maio de 2011
Ler documento completo
Amostra do texto
ETAPA № 1
Passo 1
A primeira coisa a ser feita para resolver a Situação Problema descrita e analisar o que se pede. Para isso e necessário identificar:
1. os dados de entrada do problema – dados fornecidos pelo problema e/ou pelo
usuário;
2. o(s) processamento(s) (cálculos) necessário(s) para encontrar o que e pedido;
3. o(s) dado(s) de saída do problema.
Usando as especificações feitas ecomo forma de propor uma solução para o problema, utilizem para teste apenas a conversao de Dolar Americano para Real e apresentem o algoritmo que realiza essa tarefa. Será necessário descrever:
• o algoritmo em descrição narrativa;
• o algoritmo em pseudocódigo;
• o algoritmo em fluxograma.

Descrição Narrativa

“Programa para Conversão do Dólar para Real”
1. Informe o valor em Dólarque deseja converter para Real;
2. Verifique o valor da cotação do dolar;
3. Multiplique o valor informado pelo valor da cotação do dolar;
4. Mostre o resultado convertido em real.

Pseudocódigo

“Programa para Conversão do Dólar para Real”
Inicio
//mb=moeda brasileira – real, ma=moeda americana – dolar
real: mb,ma,conversao;
mb<- 1.57;//Cotação do Dólar em 09/04/2011escreva("Digite o valor em Dolar para conversão: ");
leia(“ma”);
conversao<- ma * mb;
escreva("Valor convertido para Real: ",conversao);
fim.

Fluxograma

Passo 2
Uma vez efetuado o Passo 1, apresentem o algoritmo completo para a conversao das três moedas para o Real. Uma vez definida pelo usuário a quantia em Real, o algoritmo devera retornar o equivalente em todas as moedas, detalhando ovalor correspondente em cada uma delas.
A equipe devera apresentar o pseudocódigo e o fluxograma desse algoritmo.

Pseudocódigo
“Programa para Conversão do Dólar para Real”
inicio
//ma= Moeda Americana, mb= Moeda Brasileira, mcd= Moeda Canadense
//vlcma=Valor convertido Moeda Americana,vlcmcd=Valor convertido moeda //canadense, vlceuro= valor convertido euro.
real:mb,ma,mcd,euro,vlcma,vlcmcd,vlceuro;
ma <- 1,57;
mcd <- 1,64;
euro <- 2,27;
escreva(“Digite o valor em reais para conversão: ”);
leia (“mb”);
vlcma <- mb * ma;
vlcmcd <- mb * mcd;
vlceuro <- mb * euro;
escreva(“o valor convertido em dólar americano é: ”,vlcma);
escreva(“o valor convertido em dólar canadense é: ”,vlcmcd);
escreva (“o valorconvertido em euro é : ”vlceuro);
Fim.

Fluxograma

Passo 3
Partindo do algoritmo apresentado no Passo 2, a equipe devera altera-lo para que o usuário escolha qual e a moeda que deseja realizar a conversao.
A equipe devera apresentar o pseudocódigo do algoritmo modificado e explicar qual
estrutura de controle utilizada.
Pseudocódigo
inicio
Real: vlconvertido,mb,dolar,euro,cnd;
Inteiro:opcao;
escreva("1 - Dolar Americano");
escreva("2 - Dolar Canadense");
escreva("3 - Euro");
escreva("Informe tipo de moeda desejada: ");
leia (opcao);
Escreva("Digite o valor em reais: ");
leia (“mb”);
dolar<- 1.57;
euro<-2.64;
cnd<- 1.64;
se (opcao == 1)
então
vlconvertido <- mb * dolar;
Escreva ("o valor convertido sera = ",vlconvertido);
senão se (opcao == 2)
entãovlconvertido <- mb * cnd;
Escreva ("o valor convertido sera = ",vlconvertido);
senão se (opção == 3)
então
vlconvertido <- mb * euro;
Escreva ("o valor convertido será = ",vlconvertido);
senão
escreva(“Selecione uma moeda valida”);
fimse;
fimse;
fimse;
fimse;
fim.

ETAPA № 2

Passo 1

Nessa nova etapa do desafio sera considerada uma nova solicitação do diretor da agenciadeturismo: que o aplicativo faca conversões de nãosó para o Real, mas da moeda y para a moeda x, sendo x e y uma das moedas já definidas e que serão indicadas pelo usuário. Ou seja, o usuário escolhera uma das opções para indicar qual e a moeda base e para qual deseja verificar a conversao. Por exemplo: N Reais equivalem a M Euros – Reais e a moeda base e Euros a moeda que se deseja saber a...
tracking img