Portfolio de algoritmo

Disponível somente no TrabalhosFeitos
  • Páginas : 10 (2345 palavras )
  • Download(s) : 0
  • Publicado : 13 de novembro de 2012
Ler documento completo
Amostra do texto
algoritmo "Soma das medias"
// Função : Calcular Media De Notas
// Autor : Sergio
// Data : 04/09/2012
// Seção de Declarações
var nota1,nota2,media: real

inicio
escreval ("Digite as Notas")
leia (nota1,nota2)
media <- (nota1*2+nota2*3)/5
escreva ("O Resultado é =",media)
// Seção de Comandos
Fimalgoritmo

algoritmo "Estrutura Sequencial 5"
// Função :
// Autor : Sergio// Data : 04/09/2012
// Seção de Declarações
var a,b,c: real

inicio
escreval ("Digite Os Valores")
leia (a,b)
c <- a+b
escreva ("O Resutado é =",C)
// Seção de Comandos
Fimalgoritmo

algoritmo "Produto"
// Função : Calcular Desconto De 10 % No Produto
// Autor : Sergio
// Data : 04/09/2012
// Seção de Declarações
var prod,novo: real

inicio
escreval ("Digite o Preço doproduto")
leia (prod)
novo <- prod-(prod*0.10)
escreva ("O Novo Preço é =",novo)
// Seção de Comandos
Fimalgoritmo

algoritmo "Salario"
// Função : Calcular Salario Com A Comissão
// Autor : Sergio
// Data : 04/09/2012
// Seção de Declarações
var SL,SL1,SLN: real

inicio
escreval ("Digite Seu Salario Em Seguida Sua Comissão")
leia (SL,SL1)
SLN <- (SL1*0.04)+SL
escreva("Seu Salario Com A Comissão é =",SLN)
// Seção de Comandos
fimalgoritmo

algoritmo "Peso"
// Função : Calcular Peso
// Autor : Sergio
// Data : 05/09/2012
// Seção de Declarações
var Peso,Pesonovo,pesonovo1: real

inicio
escreval ("Digite Seu Peso")
leia (Peso)
Pesonovo <- peso+(Peso*0.15)
escreval ("Seu Peso se engordar 15% será =",pesonovo)
Pesonovo1 <-peso-(Peso*0.20)
escreval ("Seu Peso se emagrecer 20% será =",pesonovo1)
// Seção de Comandos
Fimalgoritmo

algoritmo "Peso em Gramas"
// Função : Tranformar Peso Em Gramas
// Autor : Sergio
// Data : 04/09/2012
// Seção de Declarações
var Peso,pesogramas: real

inicio
escreval ("Digite Seu Peso:")
leia (Peso)
pesogramas <- (Peso*1000)
escreval ("Seu Peso Em Gramas é =",pesogramas)
//Seção de Comandos
Fimalgoritmo

algoritmo "Trapézio"
// Função : Caculo da area de um trapezio
// Autor : Sergio
// Data : 05/09/2012
// Seção de Declarações
var res,base_menor,base_maior,altura: real
inicio

escreval ("Digite Base Maior :")
leia (base_maior)
escreval ("Digite Base Menor :")
leia (base_menor)
escreval ("Digite Altura :")
leia (altura)
res <-((base_maior+base_menor)*altura)/2
escreval ("A Area Do Trapézio é =",res)
// Seção de Comandos
Fimalgoritmo

algoritmo " Area do quadrado"
// Função : Caculo da area de um Quadrado
// Autor : Sergio
// Data : 05/09/2012
// Seção de Declarações
var lado,res: real
inicio
escreval ("Digite o lado Da Area De Um Quadrado :")
leia (lado)
res <- lado * lado
escreval ("A Area De Um Quadrado é =",res)// Seção de Comandos
fimalgoritmo

algoritmo "Losango"
// Função : Caculo da area de um Losango
// Autor : Sergio
// Data : 11/09/2012
// Seção de Declarações
var res,diagonal_menor,diagonal_maior: real
inicio

escreval ("Digite Diagonal Maior :")
leia (diagonal_maior)
escreval ("Digite Diagonal Menor :")
leia (diagonal_menor)

res <- (diagonal_maior * diagonal_menor)/2escreval ("A Area De Um Losango é =",res)
fimalgoritmo

algoritmo "Tabuada"
// Função : calcule e mostre a tabuada de um número
// Autor : Sergio
// Data : 11/09/2012
// Seção de Declarações
var n1, resultado, resultado1, resultado2, resultado3, resultado4, resultado5, resultado6, resultado7, resultado8, resultado9 ,resultado10 : real

inicio
escreval ("digite o número")
leia (n1)resultado <- (n1*0)
resultado1 <- (n1*1)
resultado2 <- (n1*2)
resultado3 <- (n1*3)
resultado4 <- (n1*4)
resultado5 <- (n1*5)
resultado6 <- (n1*6)
resultado7 <- (n1*7)
resultado8 <- (n1*8)
resultado9 <- (n1*9)
resultado10 <- (n1*10)
escreval (n1, "x0 = ",resultado)
escreval (n1, "x1 = ",resultado1)
escreval (n1, "x2 = ",resultado2)
escreval (n1, "x3 =...
tracking img