Morfologia

Disponível somente no TrabalhosFeitos
  • Páginas : 25 (6073 palavras )
  • Download(s) : 0
  • Publicado : 14 de junho de 2012
Ler documento completo
Amostra do texto
var
confere : inteiro
retornar,i : inteiro
nfilme: vetor[1..10] de inteiro
nomefilme: vetor[1..10] de caracter
valorfilme: vetor[1..10] de real
tipofilme: vetor[1..10] de caracter
lanca: vetor[1..10] de caracter
inicio
// Seção de Comandos
repita
limpatela
para i de 1 ate 10 faca
Escreva ("Entre com o código do filme a ser cadastrado:")
Leia (nfilme[i])
enquanto (nfilme[i] >8810) e (nfilme[i] <8800) faca
escreval ("Código Inválido. Tente novamente")
Escreval ("Entre com o código do filme a ser cadastrado:")
Leia (nfilme[i])
fimenquanto
Escreva ("Entre com o nome do filme a ser cadastrado:")
leia (nomefilme[i])
Escreva ("Entre com o valor do filme a ser cadastrado:")
leia(valorfilme[i])
enquanto (valorfilme[i]<>3.90)e(valorfilme[i]<>4.90) facaEscreval ("Valor inválido. Tente novamente.")
Escreval ("Entre com o valor do filme a ser cadastrado:")
leia (valorfilme[i])
fimenquanto
Escreva ("Entre com o tipo do filme a ser cadastrado:")
leia (tipofilme[i])
Escreva ("O filme é lançamento? (s/n)")
leia (lanca[i])
enquanto (lanca[i] <> "s") e (lanca[i] <> "n") faca
Escreva ("Apenas s/n")
Escreva ("O filme é lançamento?(s/n)")
fimenquanto
Escreval ("O código do filme é ", nfilme[i])
Escreval ("O nome do filme é ", nomefilme[i])
Escreval ("O valor do filme é ",valorfilme[i])
Escreval ("O tipo do filme é ", tipofilme[i])
Escreval ("Lançamento?", lanca[i])
Escreval ("Confere?(1/2)")
Leia (confere)
enquanto (confere <> 1)e(confere<>2) faca
Escreval ("Apenas 1/2")
Escreval ("Confere?(1/2)")Leia (confere)
fimenquanto
se (confere = "1") entao
retornar:=0
senao
retornar:=1
fimenquanto
fimse
fimpara
fimalgoritmovar
confere : inteiro
retornar,i : inteiro
nfilme: vetor[1..10] de inteiro
nomefilme: vetor[1..10] de caracter
valorfilme: vetor[1..10] de real
tipofilme: vetor[1..10] de caracter
lanca: vetor[1..10] de caracter
inicio
// Seção de Comandos
repita
limpatelapara i de 1 ate 10 faca
Escreva ("Entre com o código do filme a ser cadastrado:")
Leia (nfilme[i])
enquanto (nfilme[i] > 8810) e (nfilme[i] <8800) faca
escreval ("Código Inválido. Tente novamente")
Escreval ("Entre com o código do filme a ser cadastrado:")
Leia (nfilme[i])
fimenquanto
Escreva ("Entre com o nome do filme a ser cadastrado:")
leia (nomefilme[i])
Escreva ("Entre com ovalor do filme a ser cadastrado:")
leia(valorfilme[i])
enquanto (valorfilme[i]<>3.90)e(valorfilme[i]<>4.90) faca
Escreval ("Valor inválido. Tente novamente.")
Escreval ("Entre com o valor do filme a ser cadastrado:")
leia (valorfilme[i])
fimenquanto
Escreva ("Entre com o tipo do filme a ser cadastrado:")
leia (tipofilme[i])
Escreva ("O filme é lançamento? (s/n)")
leia(lanca[i])
enquanto (lanca[i] <> "s") e (lanca[i] <> "n") faca
Escreva ("Apenas s/n")
Escreva ("O filme é lançamento? (s/n)")
fimenquanto
Escreval ("O código do filme é ", nfilme[i])
Escreval ("O nome do filme é ", nomefilme[i])
Escreval ("O valor do filme é ",valorfilme[i])
Escreval ("O tipo do filme é ", tipofilme[i])
Escreval ("Lançamento?", lanca[i])
Escreval ("Confere?(1/2)")Leia (confere)
enquanto (confere <> 1)e(confere<>2) faca
Escreval ("Apenas 1/2")
Escreval ("Confere?(1/2)")
Leia (confere)
fimenquanto
se (confere = "1") entao
retornar:=0
senao
retornar:=1
fimenquanto
fimse
fimpara
fimalgoritmovar
confere : inteiro
retornar,i : inteiro
nfilme: vetor[1..10] de inteiro
nomefilme: vetor[1..10] de caracter
valorfilme: vetor[1..10] dereal
tipofilme: vetor[1..10] de caracter
lanca: vetor[1..10] de caracter
inicio
// Seção de Comandos
repita
limpatela
para i de 1 ate 10 faca
Escreva ("Entre com o código do filme a ser cadastrado:")
Leia (nfilme[i])
enquanto (nfilme[i] > 8810) e (nfilme[i] <8800) faca
escreval ("Código Inválido. Tente novamente")
Escreval ("Entre com o código do filme a ser cadastrado:")
Leia...
tracking img