Logica

Disponível somente no TrabalhosFeitos
  • Páginas : 3 (585 palavras )
  • Download(s) : 0
  • Publicado : 24 de fevereiro de 2013
Ler documento completo
Amostra do texto
1 Algoritmo nota
Inicio
Real nota;
Escreva (“solicite a nota do aluno”);
Leia (nota);
Se (nota>=7&¬a<=10)então
Escreva (“aprovado”);
Senão se (nota<7&¬a>=5)então
Escreva (“exame”);
Senão se (nota<5)então
Escreva (“reprovado”);
Senão
Escreva (“nota invalida”);
fimse
Fim
2 algoritmo categoria;
Inicio
texto opção;
Escreva (“dig1 gerente , 2 coordenador ,3 operador a ,operador b”);
Leia (opção);
chave (opção)então
Caso 1:
Escreva (“gerente”);
Parar;
Caso 2:
Escreva (“coordenador”);
Parar;
Caso 3:
Escreva(“operador a”);
Parar;
Caso 4:
Escreva (“operador b”);
Parar;
fim
3 algoritmo primo;
Inicio
Inteiro n=0,resto=0,i=0;
Booleana primo=verdadeiro;
Escreva (“dig.o numero”);
Leia (n);
Para ide 2 até n-1 faça
Resto=n%i;
Se (resto==0)então
primo= falso;
parar;
fimse
fimpara
se (primo==verdadeiro)então
escreva (“primo”);
senão
escreva (“não é primo”);
fimse
fim
4 algoritmomúltiplos de 5
Inicio
Inteiro x=0,resto=0,i=0;
Escreva(“dig.o numero”);
Leia(x);
Para(i=0;i<=x;i++);
Resto=i%5;
Se (resto!=0)então
Escreva (i);
Fimse
Fimpara
Fim
5 algoritmogratificação;
Inicio
Int cargo;
Real salario;
Escreva(“informe seu cargo 1 para gerente e 2 para operador”);
Leia (cargo);
Escreva (“dig. O seu salario”);
Leia(salario);
Se (cargo==1)entãosalario=salario*0.20;
escreva(“sua gratificação é de “,salario);
senão
salario=salario*0,12;
escreva(“sua gratificação é de “,salario);
fimse
fim
6 algoritmo múltiplos de 3
Inicio
Inteiro n=0,resto=0,i=0;Escreva(“dig o numero”);
Leia(n);
Para(i=0;i<=100;i++)
Resto=i%3;
Se (resto==0)então
Escreva(i);
Fimse
Fimpara
Fim
7 algoritmo fatorial
Inicio
Int num=0,fat=0,i=0;
Escreva(“dig o numero”);
Leia(num);
Fat=num;
Para (i=num-1;i>=1;i--)
Fat=fat*i;
fimpara
Escreva(“seu fatorial E”,num,fat);
Fim
8 algoritmo alfabeto
Inicio
Texto alfa[26];
Texto...
tracking img