Logica visual g

Disponível somente no TrabalhosFeitos
  • Páginas : 5 (1120 palavras )
  • Download(s) : 0
  • Publicado : 4 de junho de 2012
Ler documento completo
Amostra do texto
TRABALHO DE LOGICA E PROGRAMAÇAO
PROFª ELIZANGELA

algoritmo "Exercicio 1 . Faça um programa que receba dois números e mostre a subtração do primeiro pelo segundo."
// Função : Subtraçao
// Autor :
// Data : 23/3/2012
// Seção de Declarações
var
num1,num2,resul:real
inicio
escreva ("Digite o primiro numero:" )
leia (num1)
escreva ("Digite o segundo numero:" )
leia (num2)resul<-num1-num2
escreva ("O resultado da Subtracao e:" ,resul)
// Seção de Comandos
fimalgoritmo

algoritmo "Exercício 5 . Faça um programa que calcule um desconto de 10%.
// Função : Calcular o Desconto
// Autor :
// Data : 23/3/2012
// Seção de Declarações
Var
preco, valdes:real
inicio
escreva ("Digite o Valor da Etiqueta do Produto em Promocao: ")
leia (preco)
valdes<- (preco)* 0.9
escreva ("Seu Produto Custa Agora Somente: ", valdes)

// Seção de Comandos
Fimalgoritmo

algoritmo "Exercício 6.Calculo da Comissão mais Salário Final."
// Função : Calcular a Comissão
// Autor :
// Data : 24/3/2012
// Seção de Declarações
var
salfixo,vendas,comis,salfinal:real
inicio
escreva("Digite o Salario do Colaborador: ")
leia (salfixo)
escreva("O valor de Vendas no Periodo: ")
leia (vendas)
comis <- vendas * 0.04
escreval("Comissao no Periodo: ",comis)
salfinal <- salfixo+comis
escreva ("O Salario Final do Colaborador: ", salfixo+comis)

// Seção de Comandos
Fimalgoritmo

algoritmo "Exercício 9. Calculo da área de um trapézio."
// Função :Calcular Area do Trapezio
// Autor :
// Data : 24/3/2012
// Seção deDeclarações
var
baseg,basep,altura,area:real
inicio
escreval("Vamos Calcular a Area de Um Trapezio")
escreva("Digite o valor da Base Maior e tecle <enter>:" )
leia (baseg)
escreva ("Digite o valor da Base Menor e tecle <enter>: ")
leia (basep)
escreva ("Digite o valor da Altura:" )
leia (altura)
area<-((baseg+basep)*altura)/2
escreva ( "A area do Trapezio sera:", area)

//Seção de Comandos
fimalgoritmo

algoritmo " Exercicio 14 .Calculo da Idade, em dias ,meses e ano"
// Função : Calcular Idade
// Autor :
// Data : 25/3/2012
// Seção de Declarações
var
anonasc,anoatual,idames,idadias,idasema:numerico
inicio
escreva("Digite seu Ano de Nascimento Sem Ponto e digite <enter>: ")
leia (anonasc)
anoatual<- 2012 - anonasc
escreval ("A sua idadehoje é: ",anoatual)
idames <- anoatual*12
escreval ("Voce tem ...... ", idames, " meses de idade " )
idadias <-idames*365
escreval ("Voce tem ......",idadias, " dias de idade ")
idasema<- anoatual*52
escreva (" Voce tem......", idasema, " semanas de idade")

// Seção de Comandos
fimalgoritmo

algoritmo "Exercício 17: Calculo do Comprimento"
// Função: Calcular
// Autor
//Data : 25/3/2012
// Seção de Declarações
var
raio, compri,area,volume:numerico

inicio
escreval (" Vamos Calcular Comprimento, Area e Volume de uma Esfera!!!")
escreva ( " Digite o Raio da Esfera e digite <enter>: ")
leia (raio)
compri <- 2*pi*raio
escreval (" O Comprimento da Esfera é :", compri )
area<- pi*raio^2
escreval (" A Area da esfera é: ", area)
volume<-3/4*pi*raio^3
escreva ( "O volume da Esfera é :" , volume)

// Seção de Comandos
fimalgoritmo

algoritmo " Exercicio 18. Calculo da Temperatura em Celsius."
// Função : Tranformar de Celsius para Kelvin
// Autor :
// Data : 25/3/2012
// Seção de Declarações
var
celsius, fare:numerico
inicio
escreva ("Favor Informar a Temperatura em Celsius e tecle <enter>: ")
leia(celsius)
fare<- 180*(celsius + 32)/100
escreva (" A temperarura em Fahrenheit é :" ,fare )

// Seção de Comandos
Fimalgoritmo

algoritmo "Exercicio 20. Calculo do Tamanho da Escada."
// Função : Calculo da Hipotenusa
// Autor :
// Data : 25/3/2012
// Seção de Declarações
var
angulo, distparede,radiano,hipot: real

inicio
escreva (" Digite o angulo que a escada forma com...
tracking img