Logica de programacao

Disponível somente no TrabalhosFeitos
  • Páginas : 5 (1089 palavras )
  • Download(s) : 0
  • Publicado : 17 de abril de 2012
Ler documento completo
Amostra do texto
Lista 1 – Lógica de programação 2012-1
Prof. Eimard Gomes

Dado o algoritmo a seguir, responde:
Inicio
Lógico: A, B, C;


Se A = verdade, B = verdade, C = falsidade, quais comandos serão executados?
C1, C6 – Se A é verdadeiro não há necessidade de executar os outros B e C.
Se A = Falsidade, B verdade, C = falsidade, quais comandos serão executados?
C3, C4, C5 e C6.
Se A = Falsidade,B verdade, C = verdade, quais comandos serão executados?
C2, C5 e C6.
Quais São os valores de A, B, C para que somente os comandos C5 e C6 sejam executados?
A e B são falsos.
Quais São os valores de A, B, C para que somente os comandos C6 sejam executados?
Para isso A deve ser falso.

2 – Escreva um algoritmo que leia três valores inteiros e diferentes e mostre-os em ordem decrescente.Utilize para tal uma seleção encadeada.
var
a,b,c : real
inicio
escreva("DIGITE O PRIMEIRO VALOR: ")
leia(a)
escreva("DIGITE O SEGUNDO VALOR: ")
leia(B)
escreva("DIGITE O TERCEIRO VALOR: ")
leia(C)
Se (a > b) e (b > c) entao
ESCREVAL(" A ORDEM DECRESCENTE É : ",a,b,c)
senao
FIMSE
Se (a > c) e (c> b) entao
ESCREVAL(" A ORDEM DECRESCENTE É :",a,c,b)
senao
FIMSE
Se (b > a) e(a> c) entao
ESCREVAL(" A ORDEM DECRESCENTE É :",b,a,c)
senao
FIMSE
Se (b > c) e (c> a) entao
ESCREVAL(" A ORDEM DECRESCENTE É :",b,c,a)
senao
FIMSE
Se (c > b) e (b > a) entao
ESCREVAL(" A ORDEM DECRESCENTE É :",c,b,a)
Senão
FIMSE
Se (c > a) e (a> b) entao
ESCREVAL(" A ORDEM DECRESCENTE É :",C,A,B)
fimse
fimalgoritmo

3 – Desenvolva um algoritmo que calcule asraízes de uma equação do 2° grau, na forma Ax² + Bx + C, levando em consideração a existência de raízes reais.
algoritmo "Raiz quadrada"
// Função : Caucular equação do 2° grau
// Autor :
var
a, b, c, resPonten, respDelta, delta, x, x1, x2 : real
resposta : caractere
inicio

escreva ("Digite A: ")
leia (a)
escreva ("Digite B: ")
leia (b)
escreva ("Digite C: ")
leia (c)
resPonten <- (b^ 2)
delta <- ( resPonten - 4 * a * c )
se (delta > 0) entao
respDelta <- raizq(delta)
x1 <- ( ( - b + respDelta) / (2 * a) )
x2 <- ( ( - b - respDelta) / (2 * a) )
fimse
escreval (" Primeira raiz = ", x1)
escreval (" Segunda raiz = ", x2)
escreval ("O delta é: ", delta)
escreval ("A raiz quadrada é: ", respDelta)
fimalgoritmo

4 – Tendo como dados de entrada a altura e osexo de uma pessoa construa um algoritmo que calcule seu peso ideal, utilizando as seguintes fórmulas:
Para homens: (72.7 * h) – 58;
Para mulheres: (62.1 * h) – 44.7.

algoritmo "Peso ideal"

var
nome, sexo: caractere
h: real
inicio
escreval ("Digite o Nome")
leia (nome)
escreval ("Digite o Sexo")
leia (sexo)
escreval("Digite a Altura")
leia(h)
se sexo = "Homem" entao
escreval ("Seupeso Ideal é:" , (72.7 * h) - 58)

senao
escreva ("Seu peso Ideal é:" , (62.1 * h) - 44.7)
fimse

fimalgoritmo

5 – Faça um algoritmo que leia o ano de nascimento de uma pessoa, calcule e mostre sua idade e, também, verifique e mostre se ela já tem idade para votar (16 anos ou mais) e para conseguir a Carteira de Habilitação (18 anos ou mais)

algoritmo "Idade"

var
nome: caractere
an, at, idade:numerico

inicio
escreval ("Digite o Nome")
leia (nome)
escreval ("digite o ano Atual")
leia (at)
escreval ("Digite o ano de Nascimento")
leia (an)

idade <- (at - an)
escreval ("Sua idade é:" , idade)
se idade >=16 entao
escreval ("Você tem idade para votar")
senao
escreval ("Você ainda não tem pode votar")
fimse

se idade >= 18 entao
escreval ("Você pode tirar sua Carteira deHabilitação")
senao
escreval("Você não possui idade para obter Carteira de Habilitação")
fimse

fimalgoritmo

6 – Escreva um algoritmo que leia o código de um determinado produto e mostre a sua classificação. Utilize a seguinte tabela;

algoritmo "Código do produto"

var
codigo: inteiro

inicio
escreval("Digite o código do Produto")
leia(codigo)
escreval

se codigo=1 entao
escreval("Tipode produto...
tracking img