Logaritmo primeiro semestre

Disponível somente no TrabalhosFeitos
  • Páginas : 8 (1879 palavras )
  • Download(s) : 0
  • Publicado : 26 de novembro de 2012
Ler documento completo
Amostra do texto
Universidade Norte do Paraná
Thiago Viana
(Análise e Desenvolvimento de sistemas)

TECNOLOGIA DA INFORMAÇÃO NA ADMINISTRAÇÃO



Itabuna.Ba 2011


Universidade Norte do Paraná

TECNOLOGIA DA INFORMAÇÃO NA ADMINISTRAÇÃO

Produção textual interdisciplinar com base nos assuntos abordados no eixo temático, envolvendo todas as disciplinas do semestre.Itabuna.Ba 2011

 
 
SÚMARIO

Parte I – Desenvolver os seis primeiros exercícios utilizando o visuAlg.
Exercício 1 – algoritmo identificador de nº par e ímpar..........................................pág.4
Exercício 2 – algoritmo verificador de excesso de multa........................................pág.5
Exercício 3 – algoritmo verificador valor de horas detrabalho.............................pág.6
Exercício 4 – algoritmo de índice de poluição .......................................................pág.7
Exercício 5 – algoritmo de horas trabalhadas e idade de funcionários..................pág.8
Exercício 6 – algoritmo de eleições........................................................................pág.9
Exercicio 7 - Conversão de binário paradecimal..................................................pág.11

Parte II – Escrevendo em linguagem Lógica.
Tabela verdade e proposição composta T(p, q, r)..................................................pag.12

Parte III – Pesquisa de Campo.
Pesquisas em Empresas.........................................................................................pag.13

Conclusão...............................................................................................................pag.17

Resumo do Trabalho

Esse trabalho tem como objetivo apresentar as técnicas de programação 1 para implementar em atividades corriqueiras dentro de qualquer situação. Pesquisas de campo, informando tipos de sistemas, linguagens e melhorias utilizadas nas empresas da região. Aplicações de organização decomputadores.









1. Algoritmo identificador de números par, impar.

algoritmo "Numero par e impar"
// Função : imprimir numero par e impar
// Autor : Thiago Brugni, Julio Blohem, Augusto César
// Data : 10/11/2011

var

n: inteiro

inicio
// Seção de Comandos
escreval ("Digite um número para analise")
leia (n)
se n mod 2=0 entao
escreval("Este número é par")
senao
escreval ("Este número é ímpar")
fimse

fimalgoritmo

2. Algoritmo para verificar se há excesso e calcular multa.
algoritmo "Peixes e multas"
// Função : Calcular multas sobre excesso
// Autor : Thiago Brugni, Julio Blohem, Augusto César
// Data : 10/11/2011
var
p, ex, m: real
inicio
// Seção de Comandos
escreval ("Digite o peso depeixes")
leia (p)
se p > 50 entao
escreval ("Este peso excede o limite de 50kg")
ex <- (p - 50)
m <- ex * 4,00
escreval ( "peso ", p )
escreval ( "excesso ", ex )
escreval ( "multa em R$", m )
senao
escreval ("Não pagará multa")
escreval ( "peso ",p )
escreval ( "excesso ", ex )
escreval ( "multa em R$", m )
fimse
fimalgoritmo

3. Algoritmo para verificar e calcular valor de horas de trabalho.
// Função : Calcular quantidade de horas de trabalho
// Autor : Thiago Brugni, Julio Blohem, Augusto César
// Data : 10/11/2011
var
c, n, exc, salario, excedente: real
inicio
// Seção de Comandos
escreval("Digite os codigos")
leia (c)
escreval ("Digite horas trabalhadas")
leia (n)
se n > 50 entao
exc <- (n - 50)
escreval ("O excesso de horas é", exc)
salario <- 50 * 10
excedente <- exc * 20,00
escreval ("salario total R$", salario + excedente)
escreval ("salario excedente R$", excedente)...
tracking img