Lista de exercicio

Disponível somente no TrabalhosFeitos
  • Páginas : 18 (4462 palavras )
  • Download(s) : 0
  • Publicado : 28 de setembro de 2012
Ler documento completo
Amostra do texto
UniCEUB – Engenharia da Computação
Linguagens e Técnicas de Programação I - Prof. Claudionor Tusco

As conversões de português estruturado para Pascal foram feitas pelo aluno Cleber
Alves e ainda não foram todas implementadas e testadas.
Algoritmo para calcular a idade média dos alunos
Faça um programa estruturado para determinar:
(a) a quantidade de alunos do sexo masculino
(b) aquantidade de alunas do sexo feminino
(c) a idade média dos alunos
(d) a idade média das alunas
Português estruturado
Início
//Declaração de variáveis
Inteiro: iMasc, iFem, iSomaMasc, iSomaFem, iIdade;
Real: rMediaMasc, rMediaFem, rMedia;
Caracter: cSexo;
// Início das variáveis
iMasc ← 0;
iFem ← 0;
iSomaMasc ← 0;
iSomaFem ← 0;
Leia (iIdade, cSexo);
Enquanto idade > 0 faça
Se cSexo = ‘M’então
iMasc ← iMasc + 1
iSomaMasc ← iSomaMasc + iIdade;
Senão
iFem ← iFem + 1;
iSomaFem ← iSomaFem + iIdade;
Fim_se
Leia (iIdade, cSexo)
Fim_enquanto.
// Saída dos resultados
rMediaMasc ← iSomaMasc/ iMasc;
rMediaFem ← iSomaFem/ iFem;
rMedia ← [(iSomaMasc + iSomaFem) / (iMasc + iFem)];
Escreva (iMasc, rMediaMasc, iFem, rMediaFem, iMasc + iFem,
rMedia);
Fim

1

UniCEUB –Engenharia da Computação
Linguagens e Técnicas de Programação I - Prof. Claudionor Tusco

Pascal
Program nome_do_programa;
Uses crt;
Var
{Declaração de variáveis}
iMasc, iFem, iSomaMasc, iSomaFem, iIdade : Integer;
rMediaMasc, rMediaFem, rMedia : Real;
cSexo : Char;
Begin
{Início das variáveis}
iMasc := 0;
iFem := 0;
iSomaMasc := 0;
iSomaFem := 0;
Readln (iIdade, cSexo);
While idade > 0do
Begin
If cSexo = ‘M’ then
Begin
iMasc := iMasc + 1;
iSomaMasc := iSomaMasc + iIdade;
End
Else
Begin
iFem := iFem + 1;
iSomaFem := iSomaFem + iIdade;
End;
Readln (iIdade, cSexo)
End;
{Saída dos resultados}
rMediaMasc := iSomaMasc / iMasc;
rMediaFem := iSomaFem / iFem;
rMedia := [(iSomaMasc + iSomaFem) / (iMasc + iFem)];
Writeln (iMasc, rMediaMasc, iFem, rMediaFem, iMasc + iFem,rMedia);
Readkey
End.

2

UniCEUB – Engenharia da Computação
Linguagens e Técnicas de Programação I - Prof. Claudionor Tusco

Programa
Português estruturado
// foi omitida a declaração de variáveis
Início
Leia (expoente);
B ← 2;
I ← 1;
Enquanto I < expoente faça
B ← B + B;
I ← I + 1;
Fim_enquanto
Escreva (‘Resultado =’, B);
Fim.
Pascal
Program nome_do_programa;
Var
{Foiomitida a declaração de variáveis}
Begin
Readln (expoente);
B := 2;
I := 1;
While I < expoente do
Begin
B := B + B;
I := I + 1;
End;
Writeln (‘Resultado =’, B);
End.

3

UniCEUB – Engenharia da Computação
Linguagens e Técnicas de Programação I - Prof. Claudionor Tusco

Programa
Português estruturado
Início
// Declaração de variáveis
Inteiro: B, I, Expoente;
Leia(expoente);
B ← 3;
I ← 1;
Enquanto I < expoente faça
B ← B + B + B;
I ← I + 1;
Fim_enquanto
Escreva (‘Resultado = ’, B)
Fim
Pascal
Program nome_do_programa;
Var
{Declaração de variáveis}
B, I, Expoente : Integer;
Begin
Readln (expoente);
B := 3;
I := 1;
While I < expoente do
Begin
B := B + B + B;
I := I + 1;
End;
Writeln (‘Resultado = ’, B)
End.

4

UniCEUB – Engenharia daComputação
Linguagens e Técnicas de Programação I - Prof. Claudionor Tusco

Programa
Português estruturado
//Variáveis declaradas
Início
Leia (base, expoente);
B ← base;
I ← 1;
Enquanto I < expoente faça
P ← B;
J ← 1;
Enquanto J < base faça
B ← B + P;
J ← J + 1;
Fim_enquanto
I ← I + 1;
Fim_enquanto
Escreva (‘Resultado = ', B);
Fim
Pascal
Program nome_do_programa;
Var
{Variáveisdeclaradas}
Begin
Readln (base, expoente);
B := base;
I := 1;
While I < expoente do
Begin
P := B;
J := 1;
While J < base do
Begin
B := B + P;
J := J + 1;
End;
I := I + 1;
End;
Writeln (‘Resultado = ', B);
End.

5

UniCEUB – Engenharia da Computação
Linguagens e Técnicas de Programação I - Prof. Claudionor Tusco

Programa
Português estruturado
Início
Real; rN1, rN2,...
tracking img