Exercicios em portugol e c++ - programação de computadores

Disponível somente no TrabalhosFeitos
  • Páginas : 2 (296 palavras )
  • Download(s) : 0
  • Publicado : 24 de fevereiro de 2013
Ler documento completo
Amostra do texto
Exercicio 1
Portugol
Algoritmo “1 a 100”
Var
i: inteiro
Inicio
i<- 1
Enquanto ( i<=100 ) faca
EscrevaL (i)
i<-i+1
Fimenquanto
Fimalgoritmo

C++
#include<cstdlib>
#include <iostream>

using namespace std;

int main(int argc, char *argv[])
{
//Algoritmo "1a100"
//Var
int i;
//Inicio
i=int (1);
while(i<=100)
{
cout<<i<<endl;
i=i+1;
}
//FimAlgoritmo
system("PAUSE");
return EXIT_SUCCESS;
}
Exercicio 6
Portugol
Algoritmo“Exerc6”
Var
I, acPar: Inteiro
Inicio
i<-1
Enquanto ( i<100 ) faca
EscrevaL (i)
i<- i+1
acPar<- acPar+i
i<- i+1
FimEnquanto
EscrevaL (“A soma dos númerospares eh:”, acPar)
FimAlgoritmo
C++
#include <cstdlib>
#include <iostream>

using namespace std;

int main(int argc, char *argv[])
{
//Algoritmo "Exerc6"
//Var
inti, acPar;
//Inicio
i=1;
while (i<100)
{
cout<<i<<endl;
i=i+1;
acPar=acPar+i;
i=i+1;
}
cout<<"A somados numeros pares eh: "<<acPar<<endl;
//Fimalgoritmo
system("PAUSE");
return EXIT_SUCCESS;
}
Exercicio 11
Portugol
Algoritmo “ Exercicio11”
Var
i, a: inteiroInicio
Escreva (“Informe um valor->”)
Leia (i)
Escreva (“Informe outro valor->”)
Leia (a)
Enquanto ( i>=a ) faca
Escreva (“Informe outro valor maior que oprimeiro->”)
Leia (a)
FimEnquanto
Fimalgoritmo
C++
#include <cstdlib>
#include <iostream>

using namespace std;

int main(int argc, char *argv[])
{
//Algoritmo "Exercicio11"//Var
int i, a;
//Inicio
cout<<"Informe um valor->";
cin>>i;
cout<<"Informe outro valor->";
cin>>a;
while (i>=a)
{...
tracking img