Economia

Disponível somente no TrabalhosFeitos
  • Páginas : 2 (378 palavras )
  • Download(s) : 0
  • Publicado : 5 de setembro de 2012
Ler documento completo
Amostra do texto
Aluguel de carro

var
Cont: Inteiro
TipoComb, AnoFab: vetor [1..3] de Inteiro
KME, KMS, MDComb, Dist, QtdComb, ValorComb, ValorPaga: vetor [1..3] de Real
Stop, Op: Caracter
Modelo, Nome,Marca, DataIni, DataFina, TipoCarro, Dias: vetor [1..3] de Caracter
inicio
Repita
Limpatela
EscrevaL("**Menu**")
EscrevaL(" 1-Cadastra ")
EscrevaL(" 2-Calcula ")EscrevaL(" 3-Imprime ")
EscrevaL(" 4-Sair ")
EscrevaL("***************************")
EscrevaL(" Digite uma opção ")
Leia(Op)
Escolha Op
Caso "1"Escreval("**Cadastro**")
Para Cont de 1 ate 2 faca
Escreva(" Informe o nome do locatário ")
Leia(Nome[Cont])
Escreva(" Informe a classe do veículo, se A=Popular, seB=Executivo e C=Importado ")
Leia(TipoCarro[Cont])
Escreva(" Informe a marca do veículo ")
Leia(Marca[Cont])
Escreva(" Informe o modelo do veículo ")
Leia(Modelo[Cont])Escreva(" Informe o ano de fabricação ")
Leia(AnoFab[Cont])
Escreva(" Informe a data de locação ")
Leia(DataIni[Cont])
Escreva(" Informe a data de devolução ")Leia(DataFina[Cont])
Escreva(" Informe o KM inicial ")
Leia(KME[Cont])
Escreva(" Informe o KM final ")
Leia(KMS[Cont])
Escreva(" Informe o consumo médio do veículo ")Leia(MDComb[Cont])
Escreva(" informe o tipo de combustível, se for 1 alcool e se for 2 gasolina ")
Leia(TipoComb[Cont])
EscrevaL(" Tecle enter para continuar ")
Leia(Stop)Fimpara
Caso "2"
EscrevaL("**Calcula**")
Para Cont de 1 ate 2 faca
Dist[Cont]<-KMS[Cont]-KME[Cont]
QtdComb[Cont]<-Dist[Cont]/MDComb[Cont]
Se(TipoComb[Cont]=1)entaoValorComb[Cont]<-QtdComb[Cont]*2.14
Senao
ValorComb[Cont]<-QtdComb[Cont]*2.95
Fimse
Dias[Cont]<-DataFina[Cont]-DataIni[Cont]
Se(TipoCarro[Cont]=A)entao...
tracking img