Dispositivos moveis

Disponível somente no TrabalhosFeitos
  • Páginas : 4 (945 palavras )
  • Download(s) : 0
  • Publicado : 24 de maio de 2012
Ler documento completo
Amostra do texto
PROGRAMA APROVAÇÃO LISTA 12 N.01 01
variaveiss
disciplina,aluno:caracter
nota,soma:inteiro
inicio
leia (aluno)
nota<-1
ENQUANTO (nota <> 0)FACA
leia(disciplina)
leia(nota)
se(nota>=7)ENTAO
escreva ("O " ,aluno," passou com nota",nota)
fim_se
se (nota<7)ENTAO
escreva ("O aluno ",aluno," reprovou com ",nota)
fim_se
FIM_ENQUANTO
FIM

PROGRAMA LISTA 12EXERCICIO MEDIA DE IDADE 02
variaveis
MEDIA,IDADE,SOMA,SOMA2,ACUM:REAL
inicio
IDADE<--1
ACUM<--1
SOMA<-0
SOMA2<-0
ENQUANTO (IDADE <> 0) FACA
LEIA (IDADE)SOMA2<-SOMA2+IDADE
SOMA<-SOMA+1
SE (IDADE=0) ENTAO
SOMA<-SOMA-1
MEDIA<-(SOMA2/SOMA)
ESCREVA(MEDIA)
FIM_SE
FIM_ENQUANTO
FIM

PROGRAMA LISTA 12 MAIOR NUMERO LIDO 03
variaveisNUMERO,MAIORNUMERO:INTEIRO
inicio
MAIORNUMERO<-0
NUMERO<--1
ENQUANTO (NUMERO <>0) FACA
LEIA (NUMERO)
SE (NUMERO>MAIORNUMERO) ENTAO
MAIORNUMERO<-NUMERO
FIM_SE
FIM_ENQUANTO
ESCREVA (“O MAIORNUMERO É”,MAIORNUMERO)
FIM

PROGRAMA LISTA 12 LE INTEIROS 04
VARIAVEIS
NUMERO,MEN:INTEIRO
INICIO
MEN<--1
LEIA (NUMERO
ENQUANTO (NUMERO<>0)FACA
ESCREVA (NUMERO)
NUMERO<-NUMERO+MENFIM_ENQUANTO
FIM

PROGRAMA LISTA 12 SOMA DOS PARES 05
VARIAVEIS
LI,LS,SOMA,N,PARES:INTEIRO
INICIO
LEIA (LI)
LEIA (LS)
N<-LI+1
ENQUANTO (N < LS)E(N<>LS) FACA
SE (N MOD 2=0)ENTAO
PARES<-N
SOMA<-SOMA+PARES
FIM_SE
N<-N+1
FIM_ENQUANTO
ESCREVA(“A SOMA DOS NÚMEROS PARESENTRE”,LI,”E”LS,”É”,SOMA)
FIM

ROGRAMA LISTA 12 SOMA DOS IMPARES 06
VARIAVEIS
soma, i:INTEIRO
INICIO
PARA i de 1 ate 1000 passo 1 FACA
SE (i mod 2<>0) e (i mod 3=0) ENTAO
soma<-soma+i
FIM_SEFIM_PARA
ESCREVA (soma)
FIM

PROGRAMA lista 12INTEIRO SOMADO OU MULTIPLICADO 07
VARIAVEIS
A,T,S:INTEIRO
INICIO
S<-0
T<-1
REPITA
LEIA (A)
SE (A mod 2=0) ENTAO
S<-S+A...
tracking img