Construção de algoritmos - lista de exercícios - português estruturado

Disponível somente no TrabalhosFeitos
  • Páginas : 3 (578 palavras )
  • Download(s) : 0
  • Publicado : 18 de maio de 2011
Ler documento completo
Amostra do texto
Construção de Algoritmos
1) Ler 2 números e verificar qual é o maior e qual é o menor. No final, apresenta-los em ordem crescente.
01 Inicio 02 Inteiro: n1,n2; 03 Escreva("Entre com 2números: "); 04 Leia(n1,n2); 05 Se (n1 <> n2) então 06 Se (n1 > n2) então 07 Escreva("O numero ",n2," é menor que ",n1); 08 Senão 09 Escreva("O numero ",n1," émenor que ",n2);10 Fim se;
11 Senão12 Escreva("Os números digitados são iguais");13 Fim se;14 Fim.

2) Ler os nomes e os pesos de duas pessoas e imprimir os dados da pessoa com maispeso.
01 Inicio02 Real: peso1, peso2;03 Caracter: pessoa1, pessoa2;04 Escreva(“Entre com o nome e o peso da primeira pessoa: “);05 Leia(pessoa1, peso1);06 Escreva(“Entre com o nome e opeso da segunda pessoa: “);07 Leia(pessoa2, peso2);08 Se (peso1 <> peso2) então09 Se (peso1 > peso2) então10 Escreva(pessoa1," pesa mais que”, pessoa2,” e seu peso é",peso1,”Kg”);11 Senão12 Escreva(pessoa2," pesa mais que”, pessoa1,” e seu peso é ",peso2,”Kg”); 13 Fim se;14 Senão15 Escreva("Tanto “,pessoa1,” quanto “,pessoa2,”pesam “,peso1,”Kg”);16 Fim se;17 Fim.

3) Ler 5 números inteiros e apresentar apenas os números pares.
01 Inicio02 inteiro: n1,n2,n3,n4,n5,cont;03 cont <- 0;04 Escreva(“Entre com 5números inteiros: ”);05 Leia(n1, n2, n3, n4, n5);06 Escreva(“Entre os números digitados, “)07 Se (mod(n1,2) = 0) então08 Escreva(n1);09 Cont <- cont + 1;10 Fim se;
11 Se(mod(n2,2) = 0) então12 Se (cont > 0) então13 Escreva(“, “,n2);14 Cont <- cont + 1;15 Senão16 Escreva(n2);17 Cont <- cont + 1;18 Fimse;19 Fim se;20 Se (mod(n3,2) = 0) então21 Se (cont > 0) então22 Escreva(“, “,n3);23 Cont <- cont + 1;24 Senão25 Escreva(n3);26 Cont <-...
tracking img