Conceito de algoritmo

Disponível somente no TrabalhosFeitos
  • Páginas : 6 (1363 palavras )
  • Download(s) : 0
  • Publicado : 25 de abril de 2013
Ler documento completo
Amostra do texto
1
1 Conceito de Algoritmo
Um algoritmo pode ser definido como uma seqüência finita de passos (instruções) para resolver um determinado problema. Sempre que desenvolvemos um algoritmo estamos estabelecendo um padrão de comportamento que deverá ser seguido (uma norma de execução de ações) para alcançar o resultado de um problema. Para o desenvolvimento de um algoritmo eficiente é necessárioobedecermos algumas premissas básicas no momento de sua construção: . Definir ações simples e sem ambigüidade; . Organizar as ações de forma ordenada . Estabelecer as ações dentro de uma seqüência finita de passos. O algoritmo é um exemplo simples sem condições ou repetições para troca de um pneu. Os algoritmos são capazes de realizar tarefas como: 1. Ler e escrever dados; 2. Avaliar expressõesalgébricas, relacionais e lógicas; 3. Tomar decisões com base nos resultados das expressões avaliadas; 4. Repetir um conjunto de ações de acordo com uma condição; Exemplo do algoritmo Troca de pneu do carro. 1: desligar o carro 2: pegar as ferramentas (chave e macaco) 3: pegar o estepe 4: suspender o carro com o macaco 5: desenroscar os 4 parafusos do pneu furado 6: colocar o estepe 7: enroscar os 4parafusos 8: baixar o carro com o macaco 9: guardar as ferramentas Partes de Um Algoritmo Um algoritmo quando programado num computador é constituído pelo menos das 3 partes, sendo elas: 1. Entrada de dados; 2. Processamento de dados; 3. Saída de dados; Na parte de entrada, são fornecidas as informações necessárias para que o algoritmo possa ser executado. Estas informações podem ser fornecidas nomomento em que o programa está sendo executado ou podem estar embutidas dentro do mesmo. Exemplo: Pegar um ônibus. 1: ir até a parada 2: enquanto ônibus não chega faça 3: esperar ônibus 4: fim - enquanto 5: subir no ônibus 6: pegar passagem 7: se não há passagem então 8: pegar dinheiro 9:fim se 2

2
10: pagar o cobrador 11: troco dinheiro - passagem 12: enquanto banco não está vazio faça 13: irpara o próximo 14: fim enquanto 15: sentar

Pseudocódigo é uma maneira intermediária entre a linguagem natural e uma linguagem de programação representada por um algoritmo. Ela utiliza um conjunto restrito de palavras-chave, em geral na língua nativa do programador, que tem equivalentes nas linguagens de programação. Além disso, o pseudocódigo não requer toda a rigidez. Sintática necessária numalinguagem de programação, permitindo que o aprendiz se detenha na lógica dos algoritmos e não no formalismo da sua representação. Na medida em que se obtém mais familiaridade com os algoritmos, então o pseudocódigo pode ser traduzido para uma linguagem de programação. Exemplo: Exemplo de Pseudocódigo. leia (x, y) {Esta linha é um comentário} se x > y então escreva (_x é maior_) senão se y > x entãoescreva (_y é maior_) senão escreva (_x e y são iguais_) Fim-se Fim-se] Representação de dados Tipos primitivos Inteiro São os números pertencentes ao conjunto dos Inteiros, isto é, que não possuem parte fracionária. Podem ser positivos, nulos ou negativos. Exemplos: 2 laranjas,calçado tamanho 42, 0 pessoas na fila, multa de -2 pontos no campeonato. Real São os números pertencentes ao conjuntodos Reais, isto é, que podem possuir parte fracionária. Também são chamados de ponto flutuante devido à maneira como o computador os armazena. Exemplo:2:12 litros de combustível, saldo de R$ 10000:52 Caractere São os valores pertencentes ao conjunto de todos os caracteres numéricos (0...9), alfabéticos (a...z,A...Z) e especiais (! @ # $ % _ & *). Esse conjunto também é conhecido como conjunto decaracteres alfanuméricos. Os caracteres alfanuméricos são armazenados internamente no computador na forma numérica (binária) utilizando o padrão ASCII3. Lógico O tipo lógico é utilizado para representar informações que só podem assumir dois valores, o valor verdadeiro (V) ou o valor falso (F). Exemplos de informações que podem ser representadas utilizando o tipo lógico são: O fogão está apagado, a...
tracking img