Calculo de salario com algoritomo

Disponível somente no TrabalhosFeitos
  • Páginas : 2 (420 palavras )
  • Download(s) : 0
  • Publicado : 25 de maio de 2012
Ler documento completo
Amostra do texto
algoritmo "Calculo de Salário"
// Função : Calcular o Salário de um professor
// Autor : Evecimar Silva / André
// Data : 13/03/2012
// Seção de Declarações
varopcao2,opcao,titulacao,ln,nome: literal
aps: inteiro
imp,slm,ppm,vhm,vhp,apm,vha,tc,sbm,vpm:real
calculou,impr,rep:logico
inicio
// Seção de Comandos
repitaln:=(".........................................................")
se (rep) entao
escreval(ln)
escreval(ln)
escreval(ln)
fimse
escreval("Bem vindo a calculadora")
escreval("O que você deseja fazer?")
escreval("1 -Calcular Salário de um professor")
escreval("0 - Sair")
leia(opcao)
escolha opcao
caso "0"
escreval("Obrigado por utilizar nosso programa")
caso "1"
escreval("Bem vindo acalculadora de salário do professor(a)")
escreval(ln)
escreva("Digite o nome do professor(a): ")
leia(nome)
escreva("Digite quantos anos ele(a) trabalha na instituição: ")leia(tc)
escreva("Digite quantas horas ele(a) trabalhou semanalmente: ")
leia(aps)
escreval("Por favor escolha a titulação do professor(a):")escreval("(G)raduação")
escreval("(P)ós-Graduação")
escreval("(M)estrado")
escreval("(D)outorado")
leia(titulacao)
escolha titulacao
caso "g"
//Calculo para Valor da HoraProfessor Graduado
vha:=18+(tc*0.55)
calculou:=verdadeiro
caso "p"
//Calculo para Valor da Hora do professor pós-graduado
vha:=22+(tc*0.63)calculou:=verdadeiro
caso "m"
//Calculo para Valor da Hora do professor Mestrado
vha:=27+(tc*0.70)
calculou:=verdadeiro
caso "d"
//Calculo paraValor da Hora do professor doutorado
vha:=32+(tc*0.78)
calculou:=verdadeiro
outrocaso
escreva("Opção invalida")
fimescolha
se (calculou) entao...
tracking img