Atps pseudocodigo

Disponível somente no TrabalhosFeitos
  • Páginas : 2 (261 palavras )
  • Download(s) : 0
  • Publicado : 3 de abril de 2013
Ler documento completo
Amostra do texto
LIMEIRA
2012.

ALGORITIMO
NOME: CONVERSOR DE MOEDA
Inicio
Variáveis
Opção1, opção2, opção3;
Mbase1, mbase2, mbase3, mbase4, mbase5;
Valor1, valor2, valor3;
Resul1,resul2, resul3, resul4, resul5;
Inicio
Escreva ( “programa para conversão de moedas” );
Escreva ( “escolha uma moeda base” );
Escreva ( “1 – real \n 2 – dólar\n 3 – euro\n\n” );Escreva ( “opção1” );
Leia ( “opção1“ );
Se ( opção1 ==1)
Inicio;
Escreva ( “você escolheu como moeda base o real !“ );
Mbase1=1,00;
Fim se;
Se ( opção1 ==2 )
Inicio;Escreva ( “você escolheu como moeda base o dólar ! “ );
Mbase2=1,94
Mbase4=1,89
Mbase5=1,70
Fim se;
Se (opção1 ==3 )
Inicio;
Escreva ( “você escolheu como moeda base o euro !“ );
Mbase3==2,50
Fim se;
Escreva ( “você deseja fazer a conversão para qual moeda ? “ );
Escreva ( “4 – real\n 5 – dólar\n 6 – euro \n\n” );
Escreva ( “opção 2 “ );
Leia (“opção 2 “ );
Se ( opção 2 == 4 )
Inicio;
Escreva ( “você escolheu fazer a conversão para o real ! “ );
Escreva ( “digite o valor “ );
Leia ( “valor 1 “ );Resul1=((valor1*mbase1/1,00))
Escreva ( “o resultado e: R$ “, resul1 );
Se ( opção 2 ==5 )
Inicio;
Escreva ( “você escolheu fazer a conversão para o dólar ! “ );
Escreva ( “digite o valor “ );
Leia( “ valor2 “ );
Resul2=((valor2*mbase2/1,94))
Result4=((valor2*mbase4/1,94))
Resul5=((valor2*mbase5/1,94))
Escreva ( “o resultado e: R$ dólar“, resul2 );
Escreva ( “oresultado e: R$ dólar paralelo“, resul4);
Escreva ( “o resultado e: R$ dólar turismo“, resul5);

Se ( opção 2 == 6 );
Inicio;
Escreva ( “ você escolheu fazer a conversão parao euro! “ );
Escreva ( “ digite o valor “ );
Leia ( “ valor 3 “ );
Resul3=((valor3*mbase3/2,50))
Escreva ( “o resultado e: R$ “, resul3 );
Fim se;
Fim algoritmo
tracking img