Anhanguera Educacional S.A.
Curso de Ciência da Computação

Atps – Construção de Algoritmo

Parte 2

Valinhos
2010

Sumário

1. Passo 1...………………………………………………………………………3

1.1 Novos dadosincorporado no algoritmo. ..................................................3

1.2 Processamento necessário para encontrar o valor médio, o menor e o maior valor da cotação dentro de ummês...............................…….....….3

1.3 Pseudocódigo do algoritmo alterado........................................................4

2. Passo 2.....…………………………………………………………………......5

2.1Pseudocódigo do algoritmo que foi alterado para atender o solicitado no Passo 2.....................................................................................................5

2.2 Estudosdesenvolvido.......……………………………………………………9

Bibliografia.........................................................................................................10

1.1 Novos dados a serem incorporados noalgoritmo

Tipo mat;matriz [1...66][1...30] de numérico;

Para i de 1 ate 66 faça
Para j de 1 ate 30 faça
Leia(mat1[ i , j ]);
Fimpara
Fimpara

1.2 Processamento necessário paraencontrar o valor médio, o menor e o maior valor da cotação dentro de um mês

Soma 0;
Para i de 1 ate 66 faça
Para j de 1 ate 30 passo faça
Leia (mat1[ i , j ]);
Vet1 mat1 [ i ,j ];
Soma soma + vet1;
Fimpara
Fimpara

Media soma/30;

X vet1[1];
Para j de 1 ate 30 passo faça
Se vet1 [ j ] > x
X vet1[ j ];
Fimse
FimparaFimpara

Y mat1[1,1];
Para j de 1 ate 30 passo faça
Se vet1[ j ] < x
Y vet1 [ j ];
Fimse
Fimpara
Fimpara

1.3 Pseudocódigo do algoritmo alterado

AlgoritmoCotação

Tipo mat = matriz [1..66][1..30] de numérico;
Tipo vet = vetor [1..30] de numérico;

Declare

Mat1 : mat;
Soma,media,i,j,x,y,: numérico;
Vet1: vet;

Para i de 1 ate... [continua]

Ler trabalho completo

Citar Este Trabalho

APA

(2012, 05). Atps - construção de algoritmos. TrabalhosFeitos.com. Retirado 05, 2012, de http://www.trabalhosfeitos.com/ensaios/Atps-Constru%C3%A7%C3%A3o-De-Algoritmos/232415.html

MLA

"Atps - construção de algoritmos" TrabalhosFeitos.com. 05 2012. 2012. 05 2012 <http://www.trabalhosfeitos.com/ensaios/Atps-Constru%C3%A7%C3%A3o-De-Algoritmos/232415.html>.

MLA 7

"Atps - construção de algoritmos." TrabalhosFeitos.com. TrabalhosFeitos.com, 05 2012. Web. 05 2012. <http://www.trabalhosfeitos.com/ensaios/Atps-Constru%C3%A7%C3%A3o-De-Algoritmos/232415.html>.

CHICAGO

"Atps - construção de algoritmos." TrabalhosFeitos.com. 05, 2012. Acessado 05, 2012. http://www.trabalhosfeitos.com/ensaios/Atps-Constru%C3%A7%C3%A3o-De-Algoritmos/232415.html.