Atps - construção de algoritmos

Disponível somente no TrabalhosFeitos
  • Páginas: 5 (1179 palavras)
  • Download(s): 0
  • Publicado: 21 de maio de 2012
Ler documento completo
Amostra do texto
Anhanguera Educacional S.A.
Curso de Ciência da Computação

Atps – Construção de Algoritmo

Parte 2

Valinhos
2010

Sumário

1. Passo 1...………………………………………………………………………3

1.1 Novos dados incorporado no algoritmo. ..................................................3

1.2 Processamento necessário para encontrar o valor médio, o menor e o maior valor da cotação dentro de ummês...............................…….....….3

1.3 Pseudocódigo do algoritmo alterado........................................................4

2. Passo 2.....…………………………………………………………………......5

2.1 Pseudocódigo do algoritmo que foi alterado para atender o solicitado no Passo 2.....................................................................................................5

2.2 Estudosdesenvolvido.......……………………………………………………9

Bibliografia.........................................................................................................10

1.1 Novos dados a serem incorporados no algoritmo

Tipo mat;matriz [1...66][1...30] de numérico;

Para i de 1 ate 66 faça
Para j de 1 ate 30 faça
Leia(mat1[ i , j ]);
Fimpara
Fimpara

1.2 Processamento necessário paraencontrar o valor médio, o menor e o maior valor da cotação dentro de um mês

Soma 0;
Para i de 1 ate 66 faça
Para j de 1 ate 30 passo faça
Leia (mat1[ i , j ]);
Vet1 mat1 [ i , j ];
Soma soma + vet1;
Fimpara
Fimpara

Media soma/30;

X vet1[1];
Para j de 1 ate 30 passo faça
Se vet1 [ j ] > x
X vet1[ j ];
Fimse
FimparaFimpara

Y mat1[1,1];
Para j de 1 ate 30 passo faça
Se vet1[ j ] < x
Y vet1 [ j ];
Fimse
Fimpara
Fimpara

1.3 Pseudocódigo do algoritmo alterado

Algoritmo Cotação

Tipo mat = matriz [1..66][1..30] de numérico;
Tipo vet = vetor [1..30] de numérico;

Declare

Mat1 : mat;
Soma,media,i,j,x,y,: numérico;
Vet1: vet;

Para i de 1 ate 66faça
Para j de 1 ate 30 faça
Leia(mat1[ i , j ]);
Fimpara
Fimpara

Soma 0;
Para i de 1 ate 66 faça
Para j de 1 ate 30 passo faça
Leia (mat1[ i , j ]);
Vet1 mat1 [ i , j ];
Soma soma + vet1;
Fimpara
Fimpara

Media soma/30;

X vet1[1];
Para j de 1 ate 30 passo faça
Se vet1 [ j ] > x
X vet1[ j ];
FimseFimpara
Fimpara

Y mat1[1,1];
Para j de 1 ate 30 passo faça
Se vet1[ j ] < x
Y vet1 [ j ];
Fimse
Fimpara
Fimpara

Escreva (“A media do mensal é:”,media);
Escreva (“A menor cotação do mês é:”, y);
Escreva (“A maior cotação do mês é:”,x);

Fim_algoritmo
2.1 Pseudocódigo do algoritmo que foi alterado para
atender o solicitado no Passo 2

Algoritmocotação2

Tipo mat = matriz [1..66][1..30] de numérico;

Declare
Mat1 : mat;
X1,X2,X3,X4: numérico;
media1, media2, media3, media4: numérico;
soma1, soma2, soma3, soma4: numérico;
I , j , op: numérico;

Escreva (“ escolha o período do mês para analise da media, maior emenos cotação ”);

Escreva (“ 1° ao 10° dia ”);
Escreva (“ 11° ao 20° dia ”);
Escreva (“ 21° ao 30° dia ”);
Escreva (“ mês completo ”);
Escreva (“ opção “);
Leia (op)

Escolha (op)

Caso 1:
Para I de 1 ate 66
Para J de 1 ate 10
soma1 soma1 + mat1[ I , J]
fimpara
fimparaMedia1 soma1 / 10
Escreva (“ 1° ao 10° dia = ”soma1);
X1 mat1[1,1];
Para I de 1 ate 66
Para j de 1 ate 10 passo faça
Se mat1 [ i , j ] < X1
X1 mat1[ i , j ];
fimse
fimpara
fimpara
escreva (“ Menor cotação = “ X1);...
tracking img