Atps algorítimos

Páginas: 7 (1723 palavras) Publicado: 4 de outubro de 2011
Desenvolvimento

Etapa nº1:
Passo 1.
* O algoritmo em descrição narrativa:
Abra o programa;
Escolher um valor em Dólar Americano que deseja converter para Real;
Digite esse valor no programa;
Veja o valor convertido.
* O algoritmo em pseudocódigo;
Início
Real: result, valor, mbase;
Escreva (“Digite um valor em Dólar Americano que deseja converter: U$”);
Leia(valor);
mbase <- 1.88;
result <- (valor*mbase)/1.0000;
Escreva (“O valor convertido para Reais é: R$” , result);
Fim
* Início
Início
O algoritmo em fluxograma (diagrama de blocos);

Digite um valor em Dólar Americano que deseja converter: U$
Digite um valor em Dólar Americano que deseja converter: U$


Valor
Valor

1
1

Result <- (valor*mbase)/1.0000;Result <- (valor*mbase)/1.0000;
1
1

O valor convertido para Reais é: R$
O valor convertido para Reais é: R$

Fim
Fim

Passo 2.
* O algoritmo em pseudocódigo;
Início
Real: result1, result2, result3, valor;
Escreva (“Digite o valor que deseja converter:”); Leia (valor);
Result1 <- (valor*1.7700)/1.0000;
Escreva (“O valor em Dólar Americano convertido emReais é:R$”, result1);
Result2 <- (valor*1.6968)/1.0000;
Escreva (“O valor em Dólar Canadense convertido em Reais é:R$”, result2);
Result3 <- (valor*2.3525)/1.0000;
Escreva (“O valor em Euro convertido em Reais é:R$”, result3);
Fim
* Início
Início
O algoritmo em fluxograma (diagrama de blocos);

Digite o valor que deseja converter:
Digite o valor que desejaconverter:

Valor
Valor

1
1

Result1 <- (valor*1.7700)/1.0000;
Result1 <- (valor*1.7700)/1.0000;
1
1

O valor em Dólar Americano convertido em Reais é: R$
O valor em Dólar Americano convertido em Reais é: R$

Result2 <- (valor*1.6968)/1.0000;
Result2 <- (valor*1.6968)/1.0000;

O valor em Dólar Canadense convertido em Reais é: R$
O valor em Dólar Canadenseconvertido em Reais é: R$

Result3 <- (valor*2.3525)/1.0000;
Result3 <- (valor*2.3525)/1.0000;

O valor em Euro convertido em Reais é: R$
O valor em Euro convertido em Reais é: R$

Fim
Fim

Passo 3.
* O algoritmo em pseudocódigo;
Início
Real: result1, result2, result3, valor;
Inteiro: opção;
Escreva (“Digite o valor que você deseja converter:”); Leia (valor);Escreva (“Escolha a moeda que deseja converter para o Real”);
Escreva (“1-Dólar Americano 2-Dólar Canadense 3-Euro”);
Escreva (“Opção:”); Leia (opção);
Se (opção==1)
Então
Início
Escreva (“Você escolheu converter a moeda Dólar Americano”);
Result1 <- (valor*1.7700)/1.0000;
Escreva (“O valor convertido é:R$”,result1);
Fim
FimSe
Se (opção==2)
Então
Início
Escreva (“Você escolheu converter a moeda Dólar Canadense”);
Result2 <- (valor*1.7700)/1.0000;
Escreva (“O valor convertido é:R$”, result2);
Fim
FimSe
Se (opção==3)
Então
Início
Escreva (“Você escolheuconverter a moeda Euro”);
Result3 <- (valor*2.3525)/1.0000;
Escreva (“O valor convertido é:R$”, result3);
Fim
FimSe
Fim

Relatório.
No passo 1 foi pedido para que fosse criado um algoritmo em descrição narrativa, em pseudocódigo e em fluxograma de um conversor da moeda de Dólar Americano para o Real, sendo que o usuário ao abrir o programa jáira ver que ele necessita digitar um valor em Dólar Americano para assim fazer a conversão para o Real, no programa as moedas base já são definidas, então o usuário só precisa digitar o valor e mais nada, o cálculo da conversão é feito da seguinte forma, logo após o usuário digitar o valor que deseja converter, o algoritmo irá multiplicar esse valor pelo valor da moeda do Dólar Americano e por...
Ler documento completo

Por favor, assinar para o acesso.

Estes textos também podem ser interessantes

  • ATPS de Algoritimos
  • ATPS DE ALGORITIMO
  • Atps de algoritimo
  • ATPS Algoritimo
  • Atps algoritimo
  • ATPS algoritimos
  • Atps de algoritimo
  • ATPS Algorítimo

Seja um membro do Trabalhos Feitos

CADASTRE-SE AGORA!