Ativida de algorimo

Disponível somente no TrabalhosFeitos
  • Páginas : 2 (466 palavras )
  • Download(s) : 0
  • Publicado : 20 de março de 2013
Ler documento completo
Amostra do texto
1) Escreva um algoritmo que armazene o valor 10 em uma variável A e o valor 20 em uma variável B. A seguir (utilizando apenas atribuições entre variáveis) troque os seus conteúdos fazendo com queo valor que está em A passe para B e vice-versa. Ao final, escrever os valores que ficaram armazenados nas variáveis.
algoritmo "PrimeiraQuestao"
// Função : Armazenamento de Valores
// Autor : RaquelAlves Amaral
// Data : 18/03/2013
var
a,b:inteiro
inicio
a :=10
b :=20
a := a+10
b := b-10
escreval ("Variável A=", a)
escreval("Variável B=" ,b)
fimalgoritmo

2) Escreva um algoritmo para ler asdimensões de um retângulo (base e altura), calcular e escrever a área do retângulo.
3) Faça um algoritmo que leia a idade de uma pessoa expressa em anos, meses e dias e escreva a idade dessa pessoaexpressa apenas em dias. Considerar ano com 365 dias e mês com 30 dias.
algoritmo "QuestaoTres"
// Função :Ler a idade de alguem
// Autor : Raquel Alves Amara
// Data : 19/03/2013
var
nome: caracterano,mes,dias,idade: inteiro
meses: real
inicio
ano:=365
mes:=30
escreva ("Seu Nome: ")
leia (nome)
Escreva("Sua idade: ")
Leia (idade )
escreva (" sua idade corresponde à ")
dias:= (ano*idade) , " dias"escreva(dias , " dias" )
escreva(" ou ")
meses:= (dias/mes)
escreva(meses," meses")
fimalgoritmo
4) Escreva um algoritmo para ler o número total de eleitores de um município, o número de votos brancos,nulos e válidos. Calcular e escrever o percentual que cada um representa em relação ao total de eleitores.
algoritmo "QuestaoQuatro"
// Função :Total de Eleitores do Municipio X
// Autor : RaquelAlves Amaral
// Data : 19/03/2013
var
B,N,V,SOMA:inteiro
porcentagema,porcentagemb,porcentagemc :real
inicio
escreval("Municipio X tem:")
Escreva ("Número de Votos Brancos =")
Leia(B)Escreva ("Número de Votos Nulos =")
Leia(N)
Escreva ("Número de Votos Válidos = ")
Leia(V)
soma:= (b+n+v)
Escreva ("Número de Eleitores do Municipio X é" )
Escreval (soma)...
tracking img