Algoritmos

Disponível somente no TrabalhosFeitos
  • Páginas : 3 (620 palavras )
  • Download(s) : 0
  • Publicado : 30 de outubro de 2011
Ler documento completo
Amostra do texto
ALGORITMOS
REVISÃO PARA A AV1

1) O que será impresso por cada um dos comandos abaixo:
escreval((8 MOD 3) DIV 2 > (3 DIV 2) MOD 8) _____________________________________escreval((15 MOD 7) DIV (15 div 7)) _____________________________________________
escreval("sera que ",(50 DIV 8 MOD 4), " > ", (7 DIV 3 MOD 5)) _______________________
Considere:DIV = quociente inteiro - Ex: 5 DIV 2 =2
MOD = resto inteiro - Ex: 5 MOD 2 =1
2) Chico tem 1.25m de altura e Zé tem 1.10m. Chico cresce 3 cm por ano e Zé cresce 5 cm por ano. Escrevaum algoritmo que calcule e escreva quantos anos são necessários para que Zé seja maior que Chico. Escreva a altura dos dois quando Zé for maior que Chico.
Sugestão: use uma estrutura de repetição.Não é recomendável usar o para pois não sabemos, a priori, quantas vezes a repetição será executada.
Sugestão:
Algoritmo “alturas” |
Var |
Ze, Chico: |Contador:inteiro // para contar os anos necessários para Zé passar de Chico |
Inicio |
Chico |
Ze |
Contador |
enquanto (...) ou repita |... |
fimenquanto ou ate(...) |
escreval(...) |
... |
Fimalgoritmo ||


3) Atribua verdade (V) ou falso (F) para cada uma das afirmações abaixo:

( ) Todo programa que contenha o comando SE deve conter o comando SENÃOcorrespondente ao SE

( ) As estruturas de repetição ENQUANTO e REPITA executam pelo menos uma vez

( ) Sendo N1 e N2 números inteiros positivos diferentes, N1 DIV N2 e N1 MOD N2 nuncaserão iguais

( ) Não é possível atribuir pelo teclado um valor numérico para uma variável do tipo caracter

( ) Não é possível atribuir pelo teclado um valor caracter (letras)...
tracking img