Algoritmos

Disponível somente no TrabalhosFeitos
  • Páginas : 6 (1443 palavras )
  • Download(s) : 0
  • Publicado : 4 de abril de 2013
Ler documento completo
Amostra do texto
|
Exercícios aula 4 – Estrutura com seleção

1. Dados dois números A e B, some 100 ao maior número e imprima.
Var
A, b, total : inteiro
Inicio
Escreval (“digite um numero”)
Leia (a)
Escreval (“digite outro numero”)
Leia (b)
Se a>b então
Total := a+100
Escreva (“ o maior valor +100 é”, total)
Senao se a<b então
Total := b+100
Escreva (“o maior valor +100 é”, total)Fimse
fimalgoritmo


2. FUA para determinar se uma pessoa é maior ou menor de idade.

Variaveis:
Inteiro: ano_nasc, id4d3
Inicio:
Ler: (ano_nasc)
Id4d3 := (ano_nasc – 2013)
Se (id4d3 >=18) então
Escrever (“maior de idade”)
Se (id4d3 <=18) então
Escrever (“menor de idade”)
Fim_se
Fim.


3. FUA para ler dois valores numéricos e apresentar a diferença do maiorpelo menor.
Variaveis:
Num1, Num2, Dif : numerico
Inicio:
Escreva: (“Escreva o 1º numero”)
Leia: (Num1)
Escreva: (“Escreva o 2º numero”)
Leia: (Num2)
Se Num1>Num2 entao
Dif := Num1-Num2
Se não Dif := Num2 – Num1
Escreva: (“A diferença do maior para o menor é”, dif)
Fim_se
Fim.




4. FUA que leia um número e mostre uma mensagem indicando se este número é par ouímpar e se é positivo ou negativo.
Var:
Num: inteiro
Inicio:
Escreva ("digite um numero")
Leia (num)

Se (num >=0) entao
Escreva ("o numero é positivo")
Senao ("o numero é negativo")
Se (num % 2 = 0) entao
Escreval ("o numero é par")
Senao ("o numero é impar")
FIMSE
Fim.










5. FUA para ler dois números. Se os números forem iguais imprimir amensagem: "NÚMEROS IGUAIS" e encerrar a execução; caso contrário, imprimir o de maior valor.
Var:
Num1, num2 : inteiro
Inicio
Escreva ("Digite um numero")
Leia (num1)
Escreva ("digite outro numero")
Leia (num2)
Se (num1=num2) entao
Escreva ("números iguais")
Fimalgoritmo
senao num1>num2
escreva ("o numero maior é",num1)
fimalgoritmosenao (num1<num2)
escreva ("o numero maior é", num2)
Fimse
fimalgoritmo

6. FUA para ler dois valores: NUM1 e NUM2, e se NUM1 for maior que NUM2 executa a soma de NUM1 e NUM2; caso contrário, executa uma subtração.
Var
Num1, num2 , result: numérico
Inicio:
Escreva (“digite um numero”)
Leia(num1)
Escreva (“digite um outro numero”)
Leia (num2)
Se num1>num2 entao
Result := (num1+num2)
Escreva (“ a soma é”, result)
Senao result:= (num1-num2) entao
Escreva (“a subtração é”, result)
Fimse
finalalgoritmo



7. FUA que lê dois valores e escreve cada um juntamente com a mensagem: “É múltiplo de 2” ou “Não é múltiplo de dois”.
Var
Num1, num2 : inteiroInico:
Escreval (“digite um numero”)
Leia (num1)
Escreval (“digite um numero”)
Leia (num2)
Se num1=0(mod 2) => num1











8. Tendo como dados de entrada a altura e o sexo (M ou F) de uma pessoa, FUA para calcular seu peso ideal, utilizando as seguintes fórmulas:
* Para Homens: ( 72.7 * altura ) - 58;
* Para Mulheres: ( 62.1 * altura) - 44.7

Varsexo : caracter
Alt, peso, ideal_M, ideal_F : real
Inicio
Escreval (“digite sua altura”)
Leia (alt)
Escreval (“digite o sexo M ou F”)
Leia (sexo)
Se sexo=M então
Ideal_m := (72.7 * alt) – 58
Escreva (“seu peso ideal é”, ideal_m)
Senão se sexo=F então
Ideal_f := (62.1 * alt) - 44.7
Escreva (“seu peso ideal é”, ideal_f)
Fimse
fimalgoritmo

9. FUA para ler três valores a, b, ec, quaisquer e escrever o maior dos 3.
Var:
A, b, c : real
Inicio
Escreval (“digite um numero”)
Leia (a)
Escreval (“digite um numero”)
Leia (b)
Escreval (“digite um numero”)
Leia (a)
Se a<b<c entao
Escreva (“o maior numero é”, a)
Senão se b<a<c então
Escreva (“o maior numero é”, b)
Senão se c<b<a então
Escreva (“o maior numero é”, c)
Fimse...
tracking img