Algoritmos

Disponível somente no TrabalhosFeitos
  • Páginas : 5 (1037 palavras )
  • Download(s) : 0
  • Publicado : 19 de fevereiro de 2013
Ler documento completo
Amostra do texto
QUESTÃO 1
var
inicio
escreva("Vamos fazer todos os algoritmos")
fimalgoritmo
QUESTÃO 2
inicio
escreva("Aprendendo Algoritmos")
fimalgoritmo
QUESTÃO 3
var x,nome:caractere
inicio
escreva("Digite seu nome: ")
leia(x)
nome<-x
escreva("Nome :",nome)
fimalgoritmo
algoritmo "Q4"
var x,nome:caractere
inicio
escreva("Digite uma frase ")
leia(x)
nome<-x
escreva("Frase",nome)
fimalgoritmo
algoritmo "Q5"
inicio
escreva("Produto de 28 e 43 é",28*43)
fimalgoritmo
algoritmo "Q6"
inicio
escreva("Produto de 77,15 e 22 é",77*15*22)
fimalgoritmo
algoritmo "Q7"
var
x,y:inteiro
inicio
escreva("Digite um número ")
leia(x)
escreva("Digite um número ")
leia(y)
escreva("O produto deles é: ",x*y)
fimalgoritmo
algoritmo "Q8"
var
x,y:inteiro
inicioescreva("Digite o valor de A ")
leia(x)
escreva("Digite o valor de B ")
leia(y)
escreva("O triplo de A é",x*3," e o de B é",y*3,".")
fimalgoritmo
algoritmo "Q9"
var
x:real
inicio
escreva("Media entre 8,9 e 7 é ",(8+7+9)/3)
fimalgoritmo
algoritmo "Q10"
var
x:inteiro
inicio
escreva("Digite um valor ")
leia(x)
escreva("Impresso",x)
fimalgoritmo
algoritmo "Q11"
var
x,y:inteiroinicio
escreva("Digite o valor de A ")
leia(x)
escreva("Digite o valor de B ")
leia(y)
escreva("A=",x," B=",y)
fimalgoritmo
algoritmo "Q12"
var
x:inteiro
inicio
escreva("Digite um valor ")
leia(x)
escreva("Seu sucessor",x+1,"."," Seu antecessor",x-1,".")
fimalgoritmo
algoritmo "Q13"
var
nome,telefone,endereco:caractere
inicio
escreva("Digite o nome ")
leia(nome)escreva("Digite o telefone ")
leia(telefone)
escreva("Digite o endereco ")
leia(endereco)
escreva("Nome: ",nome," Telefone: ",telefone," Endereco: ",endereco)
fimalgoritmo
algoritmo "Q14"
var
a,b:inteiro
inicio
escreva("Digite o valor de A ")
leia(a)
escreva("Digite o valor de B ")
leia(b)
escreva("Soma de A e B: ",a+b)
fimalgoritmo
algoritmo "Q15"
var
a,b:inteiro
inicioescreva("Digite o valor de A ")
leia(a)
escreva("Digite o valor de B ")
leia(b)
escreva("Produto de A e B: ",a*b)
fimalgoritmo
algoritmo "Q16"
var
x:real
inicio
escreva("Digite um valor ")
leia(x)
escreva("A terça parte desse valor é",x/3)
fimalgoritmo
algoritmo "Q17"
var
y,x:real
inicio
escreva("Digite o valor de A ")
leia(x)
escreva("Digite o valor de B ")
leia(y)
escreva("Médiadesses valores é ",(x+y)/2)
fimalgoritmo
algoritmo "Q18"
var
a,b,c,d,x:real
inicio
escreva("Valor de A ")
leia(a)
escreva("Valor de B ")
leia(b)
escreva("Valor de C ")
leia(c)
escreva("Valor de D ")
leia(d)
x<-(a*1+b*2+c*3+d*4)/10
escreva("Média ponderada ",x)
fimalgoritmo
algoritmo "Q19"
var
x:inteiro
inicio
escreva("Digite um valor ")
leia(x)
escreva("O seu dobro é",x*2)
fimalgoritmo
algoritmo "20"
var
x:inteiro
inicio
escreva("Digite o ano de nascimento ")
leia(x)
escreva("Em 31/12/2013 você terá",2013-x," anos.")
fimalgoritmo
algoritmo "Q21"
var
x,y,r,q:inteiro
inicio
escreval("Valor de X: ")
leia(x)
escreval("Valor de Y: ")
leia(y)
r<-x mod y
q<-x div y
escreval
escreval("Dividendo: ",x)
escreval("Divisor: ",y)escreval("Quociente: ",q)
escreval("Resto: ",r)
fimalgoritmo
algoritmo "Q22"
var
n,d1,d2,d3,d4:inteiro
inicio
n<-1352
d4<-n mod 10
d3<-(n div 10) mod 10
d2<-(n div 100) mod 10
d1<-(n div 1000) mod 10
escreval(d4,d3,d2,d1)
fimalgoritmo
algoritmo "Q24"
var
x,d,m,a:inteiro
inicio
escreva("Digite uma data no formato DDMMAAAA ")
leia(x)
d<-x div 1000000m<-(x div 10000) mod 100
a<-x mod 100
escreval
escreval("Dia ",d)
escreval("Mês ",m)
escreval("Ano ",a)
escreval
escreval("Data ",d,"/",m,"/",a)
fimalgoritmo
algoritmo "Q25"
var
u,d,c,x:inteiro
inicio
escreval("Digite um valor na sequência CDU: ")
leia(x)
u<-x mod 10
d<-(x mod 100) div 10
c<-x div 100
escreval("O valor na sequência CDU=",x," ,trocado na sequência UCD...
tracking img