Algoritmos

Disponível somente no TrabalhosFeitos
  • Páginas : 5 (1046 palavras )
  • Download(s) : 0
  • Publicado : 20 de maio de 2012
Ler documento completo
Amostra do texto
Respostas
1) Algoritmo é um procedimento passo a passo para a solução de um problema; uma sequência detalhada de ações a serem executadas para realizar alguma tarefa. Programa de computador é um conjunto de instruções executado pelo processador em uma determinada sequência e leva o computador a executar uma tarefa.
2) As linguagens de baixo nível são aquelas linguagens de programaçãosemelhantes a linguagem de maquina. Exemplo: linguagem Assembly; as linguagens de alto nível são aquelas linguagens distantes da linguagem de maquina e próxima da linguagem humana. Exemplo: Fortran, Pascal, C, Java.
3) Compilador é um programa ou um grupo de programas que escrito por uma linguagem (esta sendo necessária de compilação para a sua execução) ao ser compilado gera outro código que éinterpretado pelo computador. Este código compilado e chamado de código objeto, podendo ser um arquivo executável que é reproduzido em um sistema operacional, por exemplo. Os compiladores analisam o código em três partes, de forma sintática ou hierárquica, análise léxica ou linear e análise semântica. O interpretador ao contrario do compilador roda o código fonte escrito como sendo o código objeto,ele traduz o programa linha a linha, o programa vai sendo utilizado na medida em que vai sendo traduzido. Cada execução do programa precisa ser novamente traduzido e interpretado. O interpretador analisa sintaticamente e semanticamente o código, se estas duas etapas forem realizadas e executadas de forma correta o código está pronto para funcionar.
4) - Linguagem natural:
Receita de bolo:-Misture os ingredientes
-Unte a forma com manteiga
-Despeje a mistura na forma
-Se houver coco ralado
Então despeje sobre a mistura
-Leve a forma ao forno
-Enquanto não corar
Deixe a forma no forno
-Retire do forno
-Deixe arrefecer
-Fluxograma:

-Pseudocódigo:

5) Var
Numero, idade: inteiro;
Numero1, altura: real;
Nome: caractere;
Menor, maior: booleano;6) ((10 div 2) + 15 resto 4) * 30 / 3 – 8 pot 2=
= ((5) + 3) * 30/3 – 64 =
= 8 * 30/3 – 64 =
= 240/3 – 64= 80 – 64 = 16

7) (((7 < 4) ou (9 = 1)) e (não (3 > 2))) ou (não (5 > 20)) =
= (((F) ou (F)) e (não(V))) ou (não(F)) =
= ((F) e (F)) ou (V) =
= (F) ou (V) = V

8)
1 algoritmo "exer_8"
2 var
3 newton,kgf:real
4 inicio
5 escreval("Entre como o valor da forcaem Newton:")
6 leia(newton)
7 kgf<-(newton*1/9.8)
8 escreval("O valor Kgf=",kgf)
9 finalgoritmo

Teste de mesa
Instrução | Linha | Newton | Kgf |
1 | 3 | ? | ? |
2 | 5 | ? | ? |
3 | 6 | [10] | ? |
4 | 7 | 10 | [1.02041] |
5 | 8 | 10 | {1.02041} |

9)
1 algoritmo "exer_9"
2 var
3 peso,altura,IMC:real
4 inicio
5 escreval("Entre com seu peso")
6 leia(peso)
7escreval("Entre com sua altura")
8 leia(altura)
9 IMC<-(peso/altura^2)
10 se (IMC<18.5) entao
11 escreval("Peso abaixo do ideal")
12 senao
13 se (IMC>=18.5)e(IMC<=24.9) entao
14 escreval("Peso Ideal")
15 senao
16 se (IMC>=25)e(IMC<=29.9) entao
17 escreval("Sobrepeso")
18 senao
19se (IMC>=30)e(IMC<=34.9) entao
20 escreval("Obesidade grau 1")
21 senao
22 se (IMC>=35)e(IMC<=39.9) entao
23 escreval("Obesidade grau 2")
24 senao
25 se (IMC>=40) entao
26escreval("Obesidade grau3)
27 fimse
28 fimse
29 fimse
30 fimse
31 fimse
32 fimse
33 finalgoritmo

Teste de Mesa
Instrução | Linha | Peso | Altura | IMC |
1 | 5 | ? | ? | ? |
2 | 6 | [80] | ? | ? |
3 | 7 | 80 | ? | ? |
4 | 8 | 80 | [1.74] | ? |
5 | 9...
tracking img