Algoritmo

Disponível somente no TrabalhosFeitos
  • Páginas : 6 (1467 palavras )
  • Download(s) : 0
  • Publicado : 18 de outubro de 2011
Ler documento completo
Amostra do texto
Curso: Sistemas de informação
Matéria: Algoritmo

1. Leia um número e exiba seu sucessor.
Algoritmo “sucessor”
Var Numero1, : inteiro
Inicio
Escreva (“digite um número”)
Leia (numero1)
Numero1 , Numero1 + 1
Escreva ( “ Resultado”, Numero1)
Fimalgoritmo
2. Calcular a quantidade dinheiro gasta por um fumante. Dados: o número de anos que ele fuma, o nº de cigarros fumados por dia e opreço de uma carteira.
Algoritmo “cigarro”
Cigarros_carteira 20
Dias_ano 365
Var anos, cigarros_dia: inteiro
Preco, total: real
Inicio
Escreva (“A quantos anos você fuma”)
Leia( anos)
Escreva(“Quantos cigarros você fuma por dia”)
Leia (cigarros_dia)
Escreva(“preço da carteira”)
Leia(preco)
Total (cigarros_dias * dias_anos * preco / cigarro_carteira) * ano
Escreva (“totalgasto”: total)
Fimalgoritmo

3. Ler dois números inteiros, x e y, e imprimir o quociente e o resto da divisão inteira entre eles.
Algoritmo “numero”
Var numerox, numeroy, quociente, resto:inteiro
Inicio
Escreva (“digite um numero”)
Leia (numerox)
Escreva (“digite um numero”)
Leia (numeroy)
Quociente numerox \ numeroy
Resto numerox mod numeroy
Escreva (“a divisão e o resto de x e y são”,quociente “e”, resto)
Fimalgoritmo

4. Que informe a área e o volume de um cilindro.

Algoritmo “ cilindro”

P 3,14

Var area, volume, altura, abase: real

Inicio

Escreva (“ informe area base”)

Leia ( abase)

Escreva (“informe altura”)

Leia (altura)

Volume P * abase^2 * altura

Area 2* P * abase * (altura + abase)

Escreva (“ resultado area”, area)
Escreva (“resultado volume” volume)

Fimalgoritmo

5. Para ler dois valores reais do teclado, calcular e imprimir na tela:
a) A soma destes valores
b) O produto deles
c) O quociente entre eles

a) algoritmo “ valores”

Var valor1, valor2, resultado:inteiro

Inicio

Escreva (“valor 1”)

Leia (valor1)

Escreva(“ valor 2”)

Leia (valor2)

Resultado valor1 + valor2

Escreva (“o valor é:”,resultado)

Fimalgoritmo

b) algoritmo “ valoresproduto”

var valor1, valor2, resultado:inteiro

Inicio

Escreva (“valor 1”)

Leia (valor1)

Escreva(“ valor 2”)

Leia (valor2)

Resultado valor1 * valor2

Escreva (“ o valor é”, resultado)

Fimalgoritmo

c) algoritmo “valoresquociente”

var valor1, valor2, resultado:inteiro

Inicio

Escreva (“valor 1”)

Leia (valor1)Escreva(“ valor 2”)

Leia (valor2)

Resultado valor1 / valor2

Escreva (“ o valor é:”, resultado)

Fimalgoritmo

6. Que gere o preço de um carro ao consumidor e os valores pagos pelo imposto e pelo lucro do distribuidor, sabendo o custo de fábrica do carro e que são pagos:
a) de imposto: 45% sobre o custo do carro; b) de lucro do distribuidor: 12% sobre o custo do carro.

Algoritmo“precocarro”

Alicota_imposto 0,45
Alicota_lucro 0,12

Var custo_carro, imposto, lucro, preco_tota:real

Inicio

Escreva (“ qual o custo de fabrica”)

Leia (custo_carro)

Imposto alicota_imposto * custo_carro

Lucro alicota_lucro * custo_carro

Preco_total imposto + lucro + custo_carro

Escreva (“ imposto”, imposto)

Escreva ( “lucro”, lucro)

Escreva (“preço total”preco_total)
Fimalgoritmo
7. Sabendo que latão é constituído de 70% de cobre e 30% de zinco, indique a
quantidade de cada um desses componentes para se obter uma certa quantidade de latão (requerida pelo usuário).

Algoritmo “ componentes”
0,70 cb
0,30 zi
Var cobre, zinco, latão:real
Inicio
Escreva(“ digite quantidade de latão desejada”)
Leia (latao)
Zinco zi *latao
Cobre cb* lataoEscreva (“quantidade de cobre é” cobre)
Escreva (“quamtidade de zinco é” zinco)
Fimalgoritmo
8. Ler os três coeficientes de uma equação de segundo grau e determinar suas raízes.
Algoritmo “ coeficientes”
var a, b, c, delta, x1, x2:real
inicio
escreva(“ digite numero para a, lembrando que a diferente de 0”)
leia (a)
escreva(“ digite numero para b”)
leia (b)
escreva(“ digite numero...
tracking img