Algoritmo

Disponível somente no TrabalhosFeitos
  • Páginas : 3 (634 palavras )
  • Download(s) : 0
  • Publicado : 16 de abril de 2013
Ler documento completo
Amostra do texto
3) Faça um algoritmo que leia 4 variáveis A,B,C e D. A seguir, se B for maior do que C
e se D for maior do que A e a soma de C com D for maior que a soma de A e B e se C e
D, ambos, forempositivos e se a variável A for par escrever a mensagem “valores
aceitos”, senão escrever “valores não aceitos”.
algoritmo "semnome"
// Função :
// Autor :
// Data : 05/10/2012
// Seção de Declaraçõesvar
A,B,C,D:inteiro
inicio
escreva("entre com o valor de A:")
leia(A)
escreva("entre com o valor de B:")
leia(B)
escreva("entre com o valor de C:")
leia(C)
escreva("entre com o valor deD:")
leia(D)
se (B>C)e(D>A)e(C+D>A+B)e(C>0)e(D>0)e(A%2=0)entao
escreva("valores aceitos")
senao
escreva("valores nao aceitos")
fimse

fimalgoritmo

7) Faça um algoritmoque leia 2 valores (x e y), que devem representar as coordenadas
de um ponto em um plano. A seguir, determine qual o quadrante ao qual pertence o
ponto, ou se está sobre um dos eixos cartesianos ouna origem (x=y=0).
algoritmo "semnome"
// Função :
// Autor :
// Data : 05/10/2012
// Seção de Declarações
var
x,y:inteiro
inicio
escreva("entre com o valor de x:")
leia(x)
escreva("entrecom o valor de y:")
leia(y)
se (x>0)e(y>0)entao
escreva("Q1")
se (x>0)e(y<0)entao
escreva("Q4")
se (x<0)e(y>0)entao
escreva("Q2")
senao
escreva("Q3")
fimse
fimse
fimsefimalgoritmo

Você resolveu dar uma força para NASA, que deseja calcular o peso das pessoas em diferentes planetas do sistema solar. (isso vai ter importantes consequências na expansão da humanidadepelos planetas). Escreva um algoritmo que recebe o peso de uma pessoa (em Newton) e calcula o novo peso nos corpos celestes, de acordo com as conversões gravitacionais de cada planeta (estasconstantes estão normalizadas em relação à constante da terra), dadas abaixo:
Corpos celestes | Fator de conversão |
Mercúrio | 0,3649 |
Venus | 0,9041 |
Marte | 0,3812 |
Lua | 0,1651 |
Terra |...
tracking img