Algoritmo

Disponível somente no TrabalhosFeitos
  • Páginas : 2 (312 palavras )
  • Download(s) : 0
  • Publicado : 14 de abril de 2013
Ler documento completo
Amostra do texto
OBS: Onde etá “programa”, leia-se “algoritmo
Exercícios de Fixação
1. Faça um programa que leia um número e imprima uma mensagem dizendo se é par ou impar.
Algoritmo inteiro nleia (n)
se (n MOD 2 == 0)
então
imprima (“Par”)
senão
imprima (“Par”)
fim_se fim
2. Faça um programa que leia 2 números e imprima uma mensagem dizendo se são iguais oudiferentes.
Algoritmo
inteiro n1, n2
leia (n1, n2) se (n1 == n2)
então
imprima (“Iguais”)
senão
imprima (“Diferentes”)
fim_se fim
3. Faça um programa que leia 2 números eimprima uma mensagem dizendo o maior deles. Suponha que os números serão diferentes.
Algoritmo
inteiro n1, n2
leia (n1, n2) se (n1 > n2)
então
imprima (“Maior e o n1 = “, n1)
senãoOBS: Agradecimentos ao prof. Cláudio Miguel (Unidade Ipanema) pela concessão deste material
imprima (“Maior e o n2 = “, n2) fim_se
fim
4. Faça um programa que leia 2 númerose imprima uma mensagem dizendo o maior deles. Detalhe: se os números forem iguais, imprima uma mensagem avisando ao usuário.
Algoritmo
inteiro n1, n2
leia (n1, n2) se (n1 > n2)então
imprima (“Maior e o n1 = “, n1)
senão
se (n2 > n1)
então
imprima (“Maior e o n2 = “, n2)
senão
imprima (“Iguais = “, n1)
fim_se fim_se
fim
5. Faça um programa queleia da entrada padrão um número e imprima o seu valor absoluto (sem o sinal).
Algoritmo real n
leia (n) se (n < 0)
então
imprima (-n)
senão
imprima (n)
fim_se fim
6. Faça umprograma que leia 3 números e imprima o menor deles.
Algoritmo
real n1, n2, n3
leia (n1, n2, n3)
se (n1 < n2) e (n1 < n3)
então
imprima (n1)
2/8
senão
se (n2 < n3)
entãoimprima (n2)
senão
imprima (n3)
fim_se fim_se
fim
7. Faça um programa que leia 3 números e os imprima em ordem crescente.
Algoritmo
real n1, n2, n3
leia (n1, n2, n3)
se (n1
tracking img