Algoritmo

Disponível somente no TrabalhosFeitos
  • Páginas : 10 (2387 palavras )
  • Download(s) : 0
  • Publicado : 15 de março de 2013
Ler documento completo
Amostra do texto
INSTITUTO FEDERAL DO TRIANGULO MINEIRO -
CAMPUS PARACATU - IFTM
1º PERÍODO DE ADS
ALGORITMO – 2ª LISTA DE EXERCICIOS



algoritmo "2.1 Quanto bate um coração"
// Função: Calcular quanto bate um coração em x anos
// Autor: Max Victor Henriques Corrêa
// Data: 06/03/2012
// Considerações: o coração humano bate em media uma vez por segundo
// 1 ano=365,25 dias 1 dia=24 horas 1 hora=60minutos 1 minuto=60
var
a:inteiro // Idade em anos
b:real // Número de Batidas
inicio
escreva("Quantos anos inteiros você tem?")
leia(a)
b<-a*365.25*24*60*60
escreva("Seu coração já bateu ",b," vezes.")
fimalgoritmo

algoritmo "2.2 Custo de uma lata de alumínio"
// Função: Calcular o custo de uma lata de alumínio
// Autor: Max Victor Henriques Corrêa
// Data: 06/03/2012
//Considerações: Custo por m² do alumínio é de R$100,00
var
r,h,ab,al,st,ca,cu:real // r: raio; h: altura; ab: área da base; al: área lateral st: área total; ca: custo alumínio; cu: custo unitário
inicio
escreva("Informe o raio da lata em metros: ")
leia(r)
escreva("Informe a altura da lata em metros: ")
leia(h)
ab<-pi*r^2
al<-2*pi*r*h
st<-2*ab+al
cu<-st*100
escreva ("Ocusto por lata é de ",cu," reais")
fimalgoritmo

algoritmo "2.3 Gerando um triangulo retângulo"
// Função: Gerar um triângulo retângulo
// Autor: Max Victor Henriques Corrêa
// Data: 06/03/2012
// Considerações: M>=2 e M>N
var
m,n,l1,l2,h:real
inicio
escreva("Digite um número inteiro maior ou igual a dois: ")
leia(m)
escreva("Agora digite um número inteiro menor que o primeiro:")
leia (n)
l1<-m^2-n^2
l2<-2*m*n
h<-m^2+n^2
escreva("A hipotenusa é ",h)
escreva(" o primeiro lado é ", l1)
escreva(" o segundo lado é ", l2)
fimalgoritmo

algoritmo "2.4 Converter graus e medidas"
// Função: Converter graus fahrenheit em graus célsius e polegada em milímetros
// Autor: Max Victor Henriques Corrêa
// Data: 06/03/2012
// Considerações: 1 polegada = 25,4 mm /Fahrenheit = 9/5 * C + 32
var
f,c,p,mm:real // f: Fahrenheit; c: Célsius; p: Polegadas; mm: Milímetros
inicio
escreva("Digite a temperatura em graus Fahrenheit: ")
leia(f)
C<- (f-32)*5/9
escreva(f," graus Fahrenheit equivale a ",c, " graus Celsius")
escreva("Digite a medida em polegadas: ")
leia(p)
mm<-25.4*p
escreva(p," polegadas equivale a ",mm," milímetros")
fimalgoritmoalgoritmo "2.5 Calcular delta"
// Função: Calcular delta
// Autor: Max Victor Henriques Corrêa
// Data: 06/03/2012
var
a,b,c,x,d: real
inicio
escreval("Seja a equação ax²+bx+c=0 informe a, b e c")
leia(a,b,c)
d<-b^2-(4*a*c)
escreva("O valor do delta é ",d)
fimalgoritmo

algoritmo "2.6 Custo de um automóvel"
// Função: Calcula o custo de um automóvel
// Autor: Max Victor HenriquesCorrêa
// Data: 06/03/2012
var
cf,ca:real
inicio
escreva("Digite o custo de fábrica do automóvel: ")
leia (cf)
ca<-cf*(1+0.12+0.3)
escreva("O custo final do automóvel é ",ca," de reais")
fimalgoritmo

algoritmo "2.7 Área e volume do cilindro"
// Função: Calcular a área total do cilindro e o volume
// Autor: Max Victor Henriques Corrêa
// Data: 06/03/2012
var
r,h,a,v :real // r:raio; h: altura; a: área; v: volume
inicio
escreva("Informe o raio do cilindro: ")
leia(r)
escreva("Informe a altura do cilindro: ")
leia(h)
a<-2*pi*r*(r+h)
v<-pi*h*r^2
escreva("A área total do cilindro é de ",a)
escreva("O volume total do cilindro é de ",v)
fimalgoritmo

algoritmo "2.8 Locadora de charretes"
// Função: calcular o valor a pagar pela charrete
// Autor: MaxVictor Henriques Corrêa
// Data: 06/03/2012
var
h:inteiro
v:real
inicio
escreva("Informe qual a quantidade de horas utilizadas: ")
leia (h)
se h<3 entao
v<-h*3.5
escreva("o valor a pagar é de ",v," reais")
senao
v<-h\3*8.5+h%3*3.50
escreval("o valor a pagar de ",v, " reais")
fimse
fimalgoritmo

algoritmo "2.9 Conversão de idade para dias"
// Função: Converter uma idade...
tracking img