Algoritmo

Disponível somente no TrabalhosFeitos
  • Páginas : 5 (1011 palavras )
  • Download(s) : 0
  • Publicado : 20 de junho de 2012
Ler documento completo
Amostra do texto
Problemas:
1º) Fazer um programa para solicitar o úmero da chamada e as duas notas (VC1 e VC2) de 67 alunos da turma T311. Para cada aluno calcular e informar seu total e a sua situação.
Obs.: Total abaixo de 7.0 = “REPROVADO”;
Total maior ou igual a 14.0 = “APROVADO”
Demais casos = “PROVA FINAL – VE”

Declaração de Variáveis
NUMC,I:inteiro
VC1,VC2,TOTAL:real
inicio
para Ide 1 ate 67 faca
escreva ("Digite o número da Chamada: ") leia (NUMC)
escreval ("Digite a 1º nota: ") leia (VC1)
escreval ("Digite a 2º nota: ") leia (VC2)
TOTAL  VC1 + VC2
se TOTAL >= 14.0 entao
escreva ("Aprovado")
senao
se TOTAL < 7.0 entao
escreva ("Reprovado")
senao
escreva ("Prova final")
fimse
fimse
fimparafimalgoritmo

2º) Deseja-se fazer o cálculo do consumo de energia elétrica gasto no mês em 44 residências de certo Condomínio. Fazer um programa para solicitar a matrícula do morador e a quantidade gasta de kWh no referido mês. Ao final informar o total de kWh gasto em todo o Condomínio.
Obs.: 1 kWh = R$ 1,23

Declaração de Variáveis
MATM,I : inteiro
KWH,TOTAL,TOTALG : real
inicio
para I de1 ate 67 faca
escreva ("Digite a Matricula do morador: ") leia (MATM)
escreva ("Digite a quantidade de kWh no mês vigente: ") leia (KWH)
TOTAL TOTAL + KWH
fimpara
TOTALG TOTAL * 1.23
escreva("Total gasto de kWh: ",TOTAL)
escreva("Total gasto em R$: ",TOTALG)
fimalgoritmo

3º) Num certo dia é necessário identificar a temperatura em n Municípios brasileiros. Fazer um programapara solicitar o CEP e a temperatura em graus Centígrados de cada Município e para cada um deles calcular e informar a temperatura correspondente em Farenheit, aplicando a fórmula a seguir. Ao final informar quantos Municípios obteve temperatura acima de 67º Farenheit.


C  5 ( F - 32)
9


Declaração de Variáveis
RESP:caractere
CEP,MUN:inteiroTEMP,FAH:real
inicio
RESP  "S"
enquanto RESP = "S" faca
escreva ("Digite o CEP: ") leia (CEP)
escreva ("Digite a Temperatura: ") leia (TEMP)
FAH  TEMP*1.8 + 32
escreva (CEP)
escreva ("Temperatura em Farenheit: ",FAH,"ºF")
se FAH > 67 entao
MUN < MUN + 1
escreva ("Deseja continuar? (S ou N)?")
leia (RESP)
fimse
fimenquanto
escreva ("Municipiosacima de 67º Farenheit: ",MUN)
fimalgoritmo

4º) Certa quantidade de acadêmicos participou de um congresso sobre energia nuclear. Confeccionar um algoritmo para pedir o número de inscrição, o nome, o sexo e a idade de cada participante e ao final informar a maior idade entre os homens (sexo=”M”) e a menor idade entre as mulheres (sexo=”F”).

Declaração de Variáveis
RESP,NOME,SEX: caractereINSC,ID,MAIORID,MENORID: inteiro
inicio
RESP  "S"
MAIORID  0
MENORID  100
enquanto RESP = "S" faca
escreva ("nº da inscrição: ") leia (INSC)
escreva ("Nome: ") leia (NOME)
escreva ("Sexo (F ou M): ") leia (SEX)
escreva ("Idade: ") leia (ID)
se (SEX= "M") e (MAIORID < ID) entao
MAIORID  ID
fimse
se (SEX="F") e (MENORID > ID) entao
MENORID  IDfimse
escreva ("Deseja continuar inserindo Dados? (S ou N)?") leia (RESP)
fimenquanto
escreva ("Maior idade entre os homens: ", MAIORID)
escreva ("Menor idade entre as mulheres: ",MENORID)
fimalgoritmo

5º) Um colégio possui 21 turmas. Crie um programa para pedir os seguintes dados de cada turma:
- código;
- quantidade de alunos do sexo feminino;
- quantidade de alunos aprovados;
-quantidade de alunos reprovados.
Para cada turma calcular e informar a porcentagem de alunos do sexo masculino e a porcentagem de aprovados.

Declaração de Variáveis
TOTAL,FEM,I,COD,APV,REP,MAS : inteiro
PORCM,ALP : real
inicio
para I de 1 ate 21 faca
escreva ("Codigo da turma: ") leia (COD)
escreva ("Quantidade de meninas: ") leia (FEM)
escreva ("Aprovados: ") leia (APV)...
tracking img