Algoritmo

Disponível somente no TrabalhosFeitos
  • Páginas : 4 (840 palavras )
  • Download(s) : 0
  • Publicado : 1 de maio de 2012
Ler documento completo
Amostra do texto
01 – Escreva um algoritmo para ler três números e imprimir a soma, média e produto
dos números lidos.

Programa: Soma/Média/Produto
        Inteiro: Soma, Média, Produto, N1, N2, N3;
Início
       Escreva (“Digite três números:”)
        Leia N1
        Leia N2
        Leia N3
        Soma = N1 + N2 + N3
        Media = N1 + N2 + N3/3
        Produto = N1 * N2 * N3
Fim.


02 -Escreva um algoritmo que leia 3(três) números inteiros e apresente o maior e o menor deles.

Programa: Maior/Menor
        Inteiro: Maior, Menor, N1, N2, N3;
Início
        Escreva (“Digite trêsnúmeros:”)
        Leia N1
        Leia N2
        Leia N3
        Maior = N1
        Menor= N1
        Se N2 > Maior Então
                Maior = N2
        Senão
                Menor = N2
       Fimse
        Se N3 > Maior Então
                Maior = N3
        Senão
                Menor = N3
        Fimse
        Escreva (“O número maior é:” Maior “e o menor é:” Menor)
Fim.03 – O custo ao consumidor de um carro novo é a soma do custo de fábrica com a percentagem do
distribuidor e dos impostos (aplicado ao custo de fábrica). Supondo que a percentagem do
distribuidorseja de 12% e os impostos de 45%, preparar um algoritmo para ler o custo de fábrica
do carro e imprimir o custo ao consumidor.

Programa: Custo de Fábrica/Consumidor
        Real: CustoC, CustoF,Perct, Impostos;
Início
        Escreva (“Digite o custo de fábrica:”)
        Leia CustoF
        Perct = (CustoF * 12)/100
        Impostos = (CustoF * 45)/100
        CustoC = CustoF + Perct+ impostos
        Escreva (“O custo ao consumidor é:” CustoC)
Fim

05 – O professor de Geografia está precisando calcular as médias das notas dos seus alunos,
para isso ele solicita que sejafeito um algoritmo que leia o nome do aluno, seguido de quatro
notas e calcule a média aritmética dizendo se o mesmo foi aprovado ou reprovado, (considere o
aluno aprovado quando a média for maior...
tracking img