Algoritmo resumam

Disponível somente no TrabalhosFeitos
  • Páginas : 5 (1117 palavras )
  • Download(s) : 0
  • Publicado : 30 de maio de 2012
Ler documento completo
Amostra do texto
Denysson Godman de M. Rosa
Denysson Godman de M. Rosa

Aprimorando seus conhecimentos em algoritmo e aprendendo a saber resolver questões sobre o assunto.
Aprimorando seus conhecimentos em algoritmo e aprendendo a saber resolver questões sobre o assunto.

Tutorial de Aprendizagem Algoritmo

Tutorial de Aprendizagem Algoritmo


Antes de começarmos a mexer no visualg, temosque primeiramente entender algoritmo que e a base fundamental desse estudo. Vejamos:
* Algoritmo: é um procedimento bem definido que recebe um conjunto de valores como entrada e produz um conjunto de valores de saída. Em outras palavras nada mais é do que a descrição de forma detalhada de informações, no nosso caso em relação à informática a descrição minuciosa de uma estrutura de um programa.A estrutura geral de um algoritmo e:
Algoritmo <“nome do algoritmo ”> Nesse espaço ficarão as informações sobre seu logaritmoVarNesse espaço ficara as variáveis que você usara no sua estrutura Inicio Nesse espaço ficara a estrutura do seu algoritmo Fimalgoritmo |

Veja como é no programa visualg:

Na construção de um algoritmo você deve entender o que o enunciado pede, e retirardele as informações que você necessita. Informações essa que você ira pedi para o usuário e também saber o que ele quer que você apresente a ele. Exemplo: na seguinte questão;
a) Faça um algoritmo que receba o nome de um aluno e suas duas notas e ao final mostre o seu nome e sua média. Dados: a nota da 1° avalição, a nota da 2° avalição.
* Repare que nessa parte do comando da questão “quereceba o nome de um aluno e suas duas notas”. Mostra para você quais serão as entradas que você terá que colocar na sua estrutura do seu algoritmo. Veja que a palavra receba foi apalavra chave para que você soubesse do que necessita do usuário.

* Nessa outra “e ao final mostre seu nome e sua média”, lhe mostra quais serão as saídas que você terá que mostrar. Veja que a pala mostre foi apalavra chave para que você soubesse o que deve mostrar ao usuário.

Agora sabendo do que eu necessito e o que devo mostrar, irei estrutura meu algoritmo. Ele iria ficar da seguinte maneira:
-------------------------------------------------

-------------------------------------------------
Algoritmo “ Média do Aluno”
-------------------------------------------------
// função: calcula amedia escolar
-------------------------------------------------
As informações sempre começam com // porque com isso o programa entende como comentário.
As informações sempre começam com // porque com isso o programa entende como comentário.
// autor: Denysson Godman
-------------------------------------------------
// data: 25/05/2012
-------------------------------------------------
Aqui asvariáveis colocadas serão aquelas irão fazer parte do seu algoritmo
Aqui as variáveis colocadas serão aquelas irão fazer parte do seu algoritmo
//n1: variável para armazena a primeira nota, n2: //variável para armazena a segunda nota, nome: //variável para armazena o nome, media: variável para //armazena a media calculada.
-------------------------------------------------
Var-------------------------------------------------
n1,n2,media: real
-------------------------------------------------
nome: caractere
-------------------------------------------------
Entre o inicio e o fimalgoritmo e o local onde e escrito a estrutura do seu algoritmo.
Para que o usuário veja na tela o que você quer use esse comando, escreva dentro das aspas:
escreva(“ ”) Para que o computadorgrave a informação digitada na viável designada use esse comando, colocando a variável dentro do parêntese : leia ( )

Entre o inicio e o fimalgoritmo e o local onde e escrito a estrutura do seu algoritmo.
Para que o usuário veja na tela o que você quer use esse comando, escreva dentro das aspas:
escreva(“ ”) Para que o computador grave a informação digitada na viável designada use...
tracking img